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About This Manual

Thismanual describes the features and functions of the NI-488.2 software
for Windows. You can use the N1-488.2 software for Windows with
Windows 95, Windows 98, Windows NT version 4.0, or Windows 2000.
This manual assumes that you are aready familiar with Windows.

Using the NI-488.2 Documentation

The following NI-488.2 documentation is available on your NI-488.2 for
Windows CD:

e The Getting Sarted card briefly describes how to install the NI-488.2
software and your GPIB hardware.

e Thismanual, NI-488.2 User Manual for Windows, describes the
features and functions of the NI-488.2 software for Windows.

*  The NI-488.2 Function Reference Manual for Windows describes the
NI-488.2 API.

*  The GPIB Hardware Guide contains detailed instructions on how to
install and configure your GPIB hardware. This guide a so includes
hardware and software specifications and compliance information.

To view these documents online, insert your NI-488.2 for Windows CD.
When the NI-488.2 Softwar e for Windows screen appears, select the
View Documentation option. The View Documentation Wizard helpsyou
find the documentation that you want to view. You can also view these
documentsat htt p: // www. nat i nst . comf manual s/ .

Accessing the NI-488.2 Online Help

The NI-488.2 for Windows Online Help addresses questions you might
have about NI-488.2, includes troubleshooting information, and describes
the NI-488.2 API. You can access the N1-488.2 online help asfollows:

1. Select Start»Programs»National I nstruments NI-488.2»Explore
GPIB.

2. ExpandtheDevicesand I nterfacesdirectory by clicking onthe + next
to the folder.

3. Right-click onyour GPIB interface and select NI-488.2 Help from the
drop-down menu that appears.

© MNational Instruments Corporation Xi NI-488.2 User Manual for Windows



About This Manual

Conventions

»

5

bold
|EEE 488 and
|IEEE 488.2

italic

nonospace

nmonospace bol d

The following conventions appear in this manual:

The » symbol leads you through nested menu items and dial og box options
to afinal action. The sequence File»Page Setup»Options directs you to
pull down the File menu, select the Page Setup item, and select Options
from the last dialog box.

Thisicon denotes a note, which alerts you to important information.

Bold text denotes items that you must select or click on in the software,
such as menu items and dialog box options. Bold text also denotes
parameter names.

|EEE 488 and | EEE 488.2 refer to the ANSI/IEEE Standard 488.1-1987
and the ANSI/IEEE Standard 488.2-1992, respectively, which define
the GPIB.

Italic text denotes variables, emphasis, across reference, or anintroduction
to akey concept. Thisfont also denotestext that is a placehol der for aword
or value that you must supply.

Text in this font denotes text or characters that you should enter from the
keyboard, sections of code, programming examples, and syntax examples.
Thisfont isalso used for the proper names of disk drives, paths, directories,
programs, subprograms, subroutines, device names, functions, operations,
variables, filenames and extensions, and code excerpts.

Bold text in thisfont denotes the messages and responses that the computer
automatically prints to the screen. This font also emphasizes lines of code
that are different from the other examples.

Related Documentation

The following documents contain information that you may find helpful as
you read this manual:

e ANSI/IEEE Standard 488.1-1987, IEEE Sandard Digital Interface
for Programmable Instrumentation

« ANSI/IEEE Standard 488.2-1992, |EEE Standard Codes, Formats,
Protocols, and Common Commands

NI-488.2 User Manual for Windows Xif www.natinst.com



Introduction

This chapter describes how to set up your GPIB system.

Setting up and Configuring Your System

Devices are usually connected with a cable assembly consisting of a
shielded 24-conductor cable with both a plug and receptacle connector at
each end. With this design, you can link devicesin alinear configuration,
astar configuration, or acombination of thetwo configurations. Figure 1-1
shows the linear and star configurations.

oC—

—

Device A

——

Device B

s

Device C

a. Linear Configuration

\
A=
=

=—

Device A

Device D

= L=

Device B

Device C

b. Star Configuration

Figure 1-1. Linear and Star System Configuration
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Chapter 1 Introduction

Controlling More Than One Interface

Figure 1-2 shows an exampl e of amultiboard system configuration. gpi b0
isthe access interface for the voltmeter, and gpi b1 isthe access interface
for the plotter and printer. The control functions of the devices
automatically access their respective interfaces.

One =
GPIB Digital
Voltometer
Another |l 880 Y —
ePB | | AU Jojonss
gpi bl
— Printer

Figure 1-2. Example of Multiboard System Configuration

Configuration Requirements

To achieve the high data transfer rate that the GPIB was designed for,
you must limit the number of devices on the bus and the physical distance
between devices. The following restrictions are typical:

¢ A maximum separation of 4 m between any two devices and an
average separation of 2 m over the entire bus.

e A maximum total cable length of 20 m.

« A maximum of 15 devices connected to each bus, with at least
two-thirds powered on.

NI-488.2 User Manual for Windows 1-2 www.natinst.com



Chapter 1 Introduction

For high-speed operation, the following restrictions apply:
* All devicesin the system must be powered on.

e  Cablelengths must be as short as possible with up to a maximum of
15 m of cable for each system.

»  There must be at least one equivalent device load per meter of cable.
If you want to exceed these limitations, you can use a bus extender to
increase the cablelength or abus expander to increase the number of device

loads. You can order bus extenders and expanders from National
Instruments.

© MNational Instruments Corporation 1-3 NI-488.2 User Manual for Windows



Measurement & Automation

Explorer

This chapter describes Measurement & Automation Explorer,
an interactive utility you can use with the N1-488.2 software.

To start Measurement & Automation Explorer, select
Start»Programs»National I1nstruments NI-488.2»Explore GPIB.

Overview

Y ou can perform the following GPIB-related tasks in Measurement &
Automation Explorer:

© MNational Instruments Corporation

Establish basic communication with your GPIB instruments.
Scan for instruments connected to your GPIB interface.

Launch the NI-488.2 Getting Started Wizard to get started with
GPIB instrument communication.

Launch the NI-488.2 Troubleshooting Wizard to troubleshoot GPIB
and NI1-488.2 problems.

Launch NI Spy to monitor NI1-488.2 or VISA API callsto GPIB
interfaces.

View information about your GPIB hardware and NI-488.2 software.
Reconfigure the GPIB interface settings.
L ocate additional help resources for GPIB and NI-488.2.

2-1 NI-488.2 User Manual for Windows



Chapter 2 Measurement & Automation Explorer

Starting Measurement & Automation Explorer

To start Measurement & Automation Explorer, select
Start»Programs»National I nstruments NI-488.2»Explore GPIB.
Figure 2-1 shows Measurement & Automation Explorer.

51 Exploring - Measurement & Automation
File Edit “iew Took Help

I@ Measurement & Automation j

|AII Folders Contents of 'Measurement & Automation’
@ Desktop Mame | Type | Walue
-2} My Computer (=8 Devices and Interfaces :

__ E;E'_ Nework Neighbohood | e AR, H
E| ¥ heasurement & Automation

@ Devices and InterfaQs

| |

=

Figure 2-1. Measurement & Automation Explorer

Getting Started with NI-488.2

To get started with GPIB instrument communication using Measurement &
Automation Explorer, complete the following steps:

1. Referto your Getting Started card and install the N1-488.2 software
and your GPIB hardware.

If you do not have a Getting Started card, complete the following steps
to view your getting started documentation:

a  Insert the NI-488.2 for Windows CD.

NI-488.2 User Manual for Windows 2-2 www.natinst.com



Chapter 2 Measurement & Automation Explorer

b. WhentheNI-488.2 Softwar efor Windows screen appears, select
the View Documentation option, as shown in Figure 2-2.

¥ NI-488.2 S oftware for Windows [x]

0OVa Install NI-488.2 Software
N AT,
A 0 for Windows

7 .,,ﬁ » View Documentation
o ; .
- R ) Vist National Instruments
o Website
2
» Explore CD
A >
J . 42 » Exit

Install and Launch LabVIEW Evaluation
Install LabWindows/CVI Evaluation
Install ComponentWorks Evaluation

Install HiQ) Student Edition

Figure 2-2. Viewing Documentation on Your CD

The View Documentation Wizard helps you find the
documentation that you want to view.

2. Usethe NI-488.2 Getting Started Wizard to verify the installation and
establish basic communication with your GPIB instruments.

@ Note After you install the NI-488.2 software and restart your system, the NI-488.2
Getting Started Wizard runs automatically. To start it within Measurement & Automation
Explorer, select Measurement & Automation in the left window pane and select
Help»Getting Started»NI-488.2 Getting Started Wizard.

After you install the NI-488.2 software and your GPIB hardware, you can
run an existing NI-488.2 application or develop anew NI-488.2
application.
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Measurement & Automation Explorer

Troubleshoot NI-488.2 Problems

To troubleshoot NI-488.2 problems, run the NI-488.2 Troubleshooting
Wizard, asfollows:

1

Select Start»Programs»National Instruments NI-488.2»Explore
GPI B to start Measurement & Automation Explorer.

Select Help»Troubleshooting»NI-488.2 Troubleshooting Wizard.

The Troubleshooting Wizard tests your GPIB interface and displays
the results, as shown in Figure 2-3.

¥ NI-488.2 Troubleshooting Wizard

v NI-488.2 Software Presence Verified
v GPIB Hardware Presence Verified

v Sequentially Yerify GPIB Interfaces

GPIE Mame | Interface Type | Statuz
GFIBO AT-GPIB/THT [Flug and Play) pazsed
Interface iz Mot Listed | Help | Retest |

Figure 2-3. NI-488.2 Troubleshooting Wizard

To view online help for the Troubleshooting Wizard, click on the Help
button.

Add a New GPIB Interface

To add anew GPIB interface to your system, compl ete the following steps:

1
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Select Start»Programs»National I nstruments NI-488.2»Explore
GPIB to start Measurement & Automation Explorer.

Select the Devices and | nterfaces folder.

In the right window pane, double-click on the Add Device or
Interfaceicon.

The Insert New dialog box appears.
Double-click on the GPIB Interface item.

If you are using Windows 98/95, the Add GPIB Hardware Wizard
appears. If you are using Windows 2000/NT, the NI-488.2
Configuration utility appears.
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5. Useeither the Add GPIB Hardware Wizard or the NI-488.2
Configuration utility to add your interface.

Delete a GPIB Interface

Before you physically remove a GPIB interface from your system, you
must remove the hardware information, as follows:

@ Note If your interfaceisa PCMCIA-GPIB, click on the PC Card icon on the taskbar to
stop the PC Card. When you stop the PC Card, the system removes the hardware
information from the Device Manager.

1. Select Start»Programs»National I nstruments NI-488.2»Explore
GPIB to start Measurement & Automation Explorer.

2. ExpandtheDevicesand I nterfacesdirectory by clicking onthe + next
to the folder.

3. Right-click on your GPIB interface and select Delete I nterface from
the drop-down menu that appears.

4. When prompted, click on the Y es button to confirm the removal of
your interface.

Scan for GPIB Instruments

To scan for instruments connected to your GPIB interface or to add a new
instrument to your system, complete the following steps:

1. Make surethat your instrument is powered on and connected to your
GPIB interface.

2. Select Start»Programs»National | nstruments NI-488.2»Explore
GPIB to start Measurement & Automation Explorer.

3. ExpandtheDevicesand I nterfacesdirectory by clicking onthe + next
to the folder.

4. Right-click onyour GPIB interface and select Scan for I nstruments
from the drop-down menu that appears.

Measurement & Automation Explorer displays the connected
instruments in the right window pane.

© National Instruments Corporation 2-5 NI-488.2 User Manual for Windows



Chapter 2

Measurement & Automation Explorer

Instruments Not Found

If thel nstruments not Found message appears in the right window
pane, Measurement & Automation Explorer did not find any instruments.
To solve this problem, make sure that your GPIB instruments are powered
on and properly connected to the GPIB interface with a GPIB cable. Then,
scan for instruments again, as described in the previous section, Scan for
GPIB Instruments.

Instruments Enumeration Failed

If thel nstrunents Enumer ati on Fai | ed message appearsintheright
window pane, Measurement & Automation Explorer found too many
Listeners on the GPIB. To solve this problem, refer to the following
possible solutions:

¢ If youhavearunning GPIB Analyzer with the GPIB handshake option
enabled, disable the GPIB handshake option in the GPIB Analyzer.

e If you have a GPIB extender in your system, Measurement &
Automation Explorer cannot detect any instruments connected to
your GPIB interface. Instead, you can verify communication with
your instruments using the Interactive Control utility. To do so,
select Tools»NI-488.2 Utilities»! nter active Control. For more
information about verifying instrument communication, type hel p
"Interactive Control:getting started" atthelnteractive
Control command prompt.

Communicate with Your Instrument

To establish basic or advanced communication with your instruments, refer
to the following sections.

For more information about instrument communication and alist of the
commands that your instrument understands, refer to the documentation
that came with your GPIB instrument. Most instruments respond to the
*| DN? command by returning an identification string.

Basic Communication (Query/Write/Read)

To establish basic communication with your instrument, use the NI-488.2
Communicator, asfollows:

1. If you have not already done so, scan for connected instruments as
described in the previous section, Scan for GPIB Instruments.

2. Sdlect Start»Programs»National Instruments NI-488.2»Explore
GPIB to start Measurement & Automation Explorer.
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3. ExpandtheDevicesand | nterfacesdirectory by clicking onthe + next
to the folder.

4. Select your GPIB interface.

Measurement & Automation Explorer displays the connected
instruments in the right window pane.

5. Right-click on your GPIB instrument and select Communicate with
I nstrument from the drop-down menu that appears.

The NI-488.2 Communicator dialog box appears, as shown in
Figure 2-4.

E.'J_'NI—-IlBB.Z Communicator [ [E] x|
GPIBO  Instrument 0 Primary Address 1

Global = Status
ibsta: w100 | | ERF
- ) T
Query I Wirite I Read | iber: Mone END
ibchitl: 4 SE
FE
String Received: CrPL
;I LK
FER
5[
AT
TAES
| LAEs
5
Show Sample| Est | DEAS

Send String:

Configured

Figure 2-4. NI-488.2 Communicator

6. Typeacommand inthe Send String field and do one of the following:

*  Towriteacommand to the instrument then read a response back,
click on the Query button.

*  Towrite acommand to the instrument, click on the Write button.
» Toread aresponse from the instrument, click on the Read button.

To view sample C/C++ code that performs a simple query of aGPIB
instrument, click on the Show Sample button.

Advanced Communication

For advanced interactive communication with GPIB instruments, use the
Interactive Control utility, as follows:

1. Select Start»Programs»National Instruments NI-488.2»Explore
GPIB to start Measurement & Automation Explorer.

2. ExpandtheDevicesand I nterfacesdirectory by clicking onthe + next
to the folder.
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Right-click on your GPIB interface and select I nteractive Control
from the drop-down menu that appears.

At the command prompt, type NI-488.2 API calls to communicate
interactively with the your instrument. For example, you might use
i bdev,ibclr,ibwt,ibrd,andibonl.

To view theonline help for Interactive Control, type hel p at the Interactive
Control command prompt.

View NI-488.2 Software Version

To view the NI-488.2 software version, complete the following steps:

1

Select Start»Programs»National Instruments NI-488.2»Explore
GPI B to start Measurement & Automation Explorer.

Select Help»About Measurement & Automation Explorer.

The Value column in the About M easurement & Automation
Explorer dialog box displays the version number of the NI1-488.2
software.

Monitor, Record, and Display NI-488.2 Calls

To monitor NI-488.2 calls, use NI Spy, asfollows:

1
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Select Start»Programs»National Instruments NI-488.2»Explore
GPI B to start Measurement & Automation Explorer.

Expand the Devicesand I nter facesdirectory by clicking on the + next
to the folder.

Right-click on your GPIB interface and select NI Spy from the
drop-down menu that appears.

Onthe NI Spy toolbar, click on the blue arrow button to start acapture.
Start the N1-488.2 application that you want to monitor.
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NI Spy recordsand displaysall NI-488.2 calls, as shown in Figure 2-5.

% HI Spy - [capture on] M=] E3
Fil= Edit “iew Spy Help
w|d| 2] sl 2|0 =% X
Mumber | GPIE Calls ihzta iberr ibcntl Time
1 ibcdes (0, 3,0 (000, T10= (132, 1, 000007 Q0 00 0 Q0000 12:53:05 496
2 ibclrf D) Q0100 0 Q0000 125207378
3 bt (ID0, "Hidn?" S (05 00100 0 00005 125315410
4 ibra(UD0, "Mational Inst.." 51 (0:337) Ox2100 0 00033 12:53:18.925
| = it UIDD, "confidc max”, 11 (0xBY) (01 00 0 0000k 1 40 416
5 b t(UIDD, "messde®™, 8 (0x8)) Ox0 00 0 00005 12:53:52.924
7 ibrafUD0, "0.9453E2.", 9 (0=9)) Ox2100 0 0=0003 12:53:56.155
4 [0
For Help, press F1 |Captured: 7, Displayed: 7 v

Figure 2-5. NI-488.2 Calls Recorded by NI Spy

For more information about using NI Spy, select Help»Help Topicsin
NI Spy or refer to Chapter 5, NI Spy Utility.

View or Change GPIB Interface Settings

Windows 98/95

To view or change the settings of your GPIB interface, refer to one of the
following sections.

To view or change your interface settingsin Windows 98/95, complete the
following steps:

1. Select Start»Programs»National I nstruments NI-488.2»Explore
GPIB to start Measurement & Automation Explorer.

2. ExpandtheDevicesand I nterfacesdirectory by clicking onthe + next
to the folder.

3. Right-click on your GPIB interface and select Properties from the
drop-down menu that appears.
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The Properties dialog box appears. Figure 2-6 shows the Properties
dialog box for an AT-GPIB/TNT (Plug and Play) interface.

AT-GPIB/THT [Plug and Play] Properties EHE
NI-485.2 Settings |

V AT-GPIB/TNT [Plug and Play]

=154 PrP Serial Humber 00003635

Interface Hame — Termination Methods
IR =~ | ¥ Send EOI at end of Wiits
GFIB &ddress [~ Teminate Read on EOS
Primery I SetEO with EQS on'wiite
IU :[. [~ &hit EOS Compare
_|S—_|: ;;n; = [0 EpsBye

1/0 Timeout

I 10zec j' Advanced... |

¥ System Controller

,TI Cancel | Al |

Figure 2-6. Properties Dialog Box in Windows 98/95

If you need more information about afield in the Properties dialog
box, click on the ? button in the upper-right corner of the dialog box,
then click on the field.

4. (Optional) Change the settings for your interface.

Windows 2000/NT
To view or change GPIB interface information, complete the following
steps:
1. Select Start»Programs»National I nstruments NI-488.2»Explore
GPIB to start Measurement & Automation Explorer.

2. ExpandtheDevicesand Interfacesdirectory by clicking onthe + next
to the folder.

3. Right-click on your GPIB interface and select Properties from the
drop-down menu that appears.
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The GPIB Configuration dialog box appears. Figure 2-7 shows the
GPIB Configuration dialog box for an AT-GPIB/TNT (Plug and
Play) interface in Windows NT.

GFPIB Configuration - GPIBD [AT-GPIB/TNT(...

GPIE Board w Device Template

DEY1 -

Configure | DEV2

DEY3

DEve x|
Board Type

Ok I LCancel | Help | Unload I

Figure 2-7. GPIB Configuration Utility in Windows NT

4. Select your GPIB Board and click on the Configure button.
5. (Optional) Change the settings for your interface.

For more information about changing the settings for your interface, click
on the Help button.

View GPIB Instrument Information

To view information about your GPIB instruments, complete thefollowing

steps:

1. If you have not already done so, scan for connected instruments as
described in the Scan for GPIB Instruments section earlier in this
chapter.

2. Select Start»Programs»National Instruments NI1-488.2»Explore
GPIB to start Measurement & Automation Explorer.

3. ExpandtheDevicesand I nterfacesdirectory by clicking onthe + next
to the folder.

4. Select your GPIB interface.

Measurement & Automation Explorer displays the connected
instruments in the right window pane. Table 2-1 describes the
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instrument information that Measurement & Automation Explorer

displays.

Table 2-1. Measurement & Automation Explorer Instrument Information

Column Description

Name Logical instrument name assigned by Measurement &
Automation Explorer

Type Instrument’s response to the identification query
(*1 DN?)

Value Primary (PAD) and secondary (SAD) addresses of the
instrument

Description I dentifies the instrument as a GPIB instrument

Change GPIB Device Templates

For older NI-488.2 applications, you might need to modify one of the
device templates to find a given GPIB instrument by name, for example,
i bfi nd("fl uke45") . Older applications still usei bf i nd instead of the
preferredi bdev to obtain adevice handle. In new applications, avoid using
i bf i nd to obtain device handles and usei bdev instead. Y ou can use

i bdev to dynamically configure your GPIB device handle. i bdev also
eliminates unneccessary device name requirements.

If you must modify adevicetemplate, refer to one of thefollowing sections.

To reconfigure GPIB device templates in Windows 98/95, complete the

Windows 98/95
following steps:
1.
2.
3.
button.
7.

NI-488.2 User Manual for Windows

Select Start»Settings»Control Panel.
Double-click on the System icon.
Select the Device M anager tab and click onthe View devicesby type

Click on the National Instruments GPIB I nterfacesicon.

Click on the Properties button.

Select the Device Templatestab and rename the templ ate as described
in your application documentation.

Click on the OK button twice to save your changes and exit.
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Windows 2000/NT

To reconfigure GPIB devicetemplatesin Windows 2000/NT, completethe

following steps:

1. Select Start»Programs»National Instruments NI-488.2»Explore
GPIB to start Measurement & Automation Explorer.

2. ExpandtheDevicesand I nterfacesdirectory by clicking onthe + next
to the folder.

3. Right-click on any GPIB interface and select Propertiesfrom the
drop-down menu that appears.
Select the device template that you want to modify, such as DEV 1.

5. Click on the Configure button and rename the device template as
described in your application documentation.

6. Click onthe OK button twice to save your changes and exit.

Enable/Disable NI-488.2 DOS Support

To enable or disable DOS support for your NI1-488.2 application, refer to
one of the following sections.

Windows 98/95

To enable or disable NI-488.2 DOS support in Windows 98/95, complete
the following steps:

1.
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Make sure that no older version of the NI1-488.2 DOS device driver is
being loaded from your conf i g. sys file. To do so, complete the
following steps:
a Locateyour confi g. sys fileand open it for editing.
b. Findthefollowing line:

devi ce=<pat h>\ gpi b. com

where <pat h> refersto the drive and directory where gpi b. com
islocated.

c. If that line appears, type REMat the beginning of theline, as
follows:

REM devi ce=<pat h>\ gpi b. com
d. Saveyourconfig. sys fileand closeit.

Select Start»Programs»National Instruments NI-488.2»Explore
GPIB to start Measurement & Automation Explorer.
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3. ExpandtheDevicesand I nterfacesdirectory by clicking onthe+ next
to the folder.

4. Click onyour GPIB interface and select T ools»Settings»NI-488.2
from the Explorer menu.

5. Enable or disable DOS support in the NI-488.2 Settings dialog box
and click on the OK button.

6. If you are prompted to do so, restart your system.

Windows 2000/NT

To enable NI-488.2 DOS support in Windows 2000/NT, compl ete the

following steps:

1. Openyourconfi g. nt file, located in the Windows NT system32
directory (for example, c: \ wi ndows\ syst en82).

2. Find thefollowing lines:
REM ***To run DOS GPI B applications, unconment the
REM ***fol | om ng |ine
REM devi ce=<pat h>\ doswi n16\ gpi b-nt.com
where <pat h> isthe directory in which you installed the NI-488.2
software.

3.  Remove REMfrom the last line so that it reads as follows:

devi ce=<pat h>\ doswi n16\ gpi b-nt. com

To disable DOS support, add REMback to the line where it was removed.

Access Additional Help and Resources

To access additional help and resources for the N1-488.2 software and your
GPIB hardware, refer to the following sections.

NI-488.2 Online Help

The NI-488.2 for Windows Online Help addresses questions you might
have about N1-488.2, includes troubleshooting information, and describes
the NI-488.2 API. You can access the NI1-488.2 online help as follows:

1
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Select Start»Programs»National Instruments NI-488.2»Explore
GPI B to start Measurement & Automation Explorer.

Expand the Devicesand I nterfacesdirectory by clicking onthe + next
to the folder.
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3. Right-click onyour GPIB interface and select N1-488.2 Help from the
drop-down menu that appears.

National Instruments GPIB Web Site

To access the National Instruments Web site for GPIB, select
Start»Programs»National 1 nstruments NI-488.2»Explore GPIB to
start Measurement & Automation Explorer. Then, select Help»National
Instruments on the Web»GPIB Home Page.

View or Change GPIB-ENET Network Settings
(Windows 98/95 Only)

To view or change the network settings of your GPIB-ENET, refer to the
following sections. For moreinformation about your GPIB-ENET network
settings, refer to the Getting Started with Your GPIB-ENET and the
NI-488.2 Software for Windows 98/95 manual.

Assign IP Address

You can run the Assign |P Address utility in Measurement & Automation
Explorer, asfollows:

1. Contact your network administrator to determine whether you should
use the Assign IP Address utility to assign the I P address manually.

2. Select Start»Programs»National | nstruments NI-488.2»Explore
GPIB to start Measurement & Automation Explorer.

3. ExpandtheDevicesand | nterfacesdirectory by clicking onthe + next
to the folder.

4. Right-click on your GPIB-ENET interface and select Assign IP
Addr ess from the drop-down menu that appears.

To view the built-in, context-sensitive help for the Assign IP Address
utility, click on the Help button.

Configure Advanced IP Settings

Y ou can run the Advanced | P Settings utility in Measurement &
Automation Explorer, asfollows:

1. Contact your network administrator.

2. Select Start»Programs»National Instruments NI-488.2»Explore
GPIB to start Measurement & Automation Explorer.
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3. ExpandtheDevicesand I nterfacesdirectory by clicking onthe+ next
to the folder.

4. Right-click on your GPIB-ENET interface and select Advanced | P
Settings from the drop-down menu that appears.

To view the built-in, context-sensitive help for the Advanced IP Settings
utility, click on the Help button.

Update GPIB-ENET Firmware

Y ou can run the Update Firmware utility in Measurement & Automation
Explorer, asfollows:

1. Select Start»Programs»National I nstruments NI-488.2»Explore
GPIB to start Measurement & Automation Explorer.

2. ExpandtheDevicesand Interfacesdirectory by clicking onthe + next
to the folder.

3. Right-click on your GPIB-ENET interface and select Update
Firmwar e from the drop-down menu that appears.

To view the built-in, context-sensitive hel p for the Update Firmware utility,
click on the Help button.
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Application

This chapter describes how to develop an NI-488.2 application using the
NI-488.2 API.

Simple Instrument Control

To establish basic communication with your instrument, use the NI-488.2
Communicator, as follows:

1.
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If you have not already done so, scan for connected instruments as
described in the Scan for GPIB Instruments section in Chapter 2,
Measurement & Automation Explorer.

Select Start»Programs»National 1 nstruments NI-488.2»Explore
GPIB to start Measurement & Automation Explorer.

Expand the Devicesand | nter facesdirectory by clicking onthe + next
to the folder.

Select your GPIB interface.

Measurement & Automation Explorer displays the connected
instruments in the right window pane.

Right-click on your GPIB instrument and select Communicate with
I nstrument from the drop-down menu that appears.
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The NI-488.2 Communicator dialog box appears, as shownin
Figure 3-1.

Tﬂ NI-488.2 Communicator

GPIBD  Instrument 0 Primary Address 1

Glabal

Send String: K bt D100
Blueny | “frite | Bead | iberm: Mane
Configured ibcrith: 4
Sting Received:
[—
| -
Show Sample | Exit |

— Status

BRH
Tk
B
SH]
FABLE
CMPL
Lk
Bt
(][5
AT
TAES
(A5G
[

[HEAS

Figure 3-1. NI-488.2 Communicator

6. Typeacommand inthe Send String field and do one of the following:

To write acommand to the instrument then read a response back,
click on the Query button.

To write acommand to the instrument, click on the Write button.
To read aresponse from the instrument, click on the Read button.

To view sample C/C++ code that performs a simple query of aGPIB
instrument, click on the Show Sample button.

Interactive Instrument Control

Before you write your NI-488.2 application, you might want to use the
Interactive Control utility to communicate with your instruments
interactively by typing individual commandsrather than issuing them from
an application. Y ou can also use the Interactive Control utility to learn to
communicate with your instruments using the NI-488.2 API. For specific
device communication instructions, refer to the documentation that came
with your instrument. For information about using the Interactive Control
utility and detailed examples, refer to Chapter 6, Interactive Control

Utility.
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For advanced interactive communication with GPIB instruments, use the
Interactive Control utility, as follows:

1. Select Start»Programs»National Instruments NI-488.2»Explore
GPIB to start Measurement & Automation Explorer.

2. ExpandtheDevicesand I nterfacesdirectory by clicking onthe + next
to the folder.

3. Right-click on your GPIB interface and select | nteractive Control
from the drop-down menu that appears.

4. At the command prompt, type NI-488.2 API calls to communicate
interactively with the your instrument. For example, you might use
i bdev,ibclr,ibwt,ibrd,andi bonl.

Toview theonline help for Interactive Control, type hel p at the Interactive
Control command prompt. For more information, refer to Chapter 6,
Interactive Control Utility.

Choosing Your Programming Methodology

Based on your devel opment environment, you can select amethod for
accessing the driver, and based on your NI-488.2 programming needs, you
can choose how to use the NI-488.2 API.

Choosing a Method to Access the NI-488.2 Driver

Applications can access the NI1-488.2 dynamic link library (DLL),
gpi b- 32. dI |, either by using an NI-488.2 language interface or by direct
access.

NI-488.2 Language Interfaces

Y ou can use alanguage interface if your program is written in Microsoft
Visual C/C++ (2.0 or later), Borland C/C++ (4.0 or later), or Microsoft
Visual Basic (4.0 or later). Otherwise, you must access gpi b- 32. dl |
directly.

Direct Entry Access

Y ou can accessthe DLL directly from any programming environment that
allows you to request addresses of variables and functions that a DLL
exports. gpi b- 32. dI | exports pointersto each of the global variablesand
all the NI1-488.2 calls.
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Choosing How to Use the NI-488.2 API

The NI-488.2 APl has two subsets of callsto meet your application needs.
Both of these sets, the traditional calls and the multi-device calls, are
compatible across computer platforms and operating systems, so you can
port programsto other platformswith little or no source code modification.
For most applications, the traditional NI-488.2 calls are sufficient. If you
have a complex configuration with one or more interfaces and multiple
devices, use the multi-device NI-488.2 calls. Whichever option you
choose, bus management operations necessary for device communication
are performed automatically.

The following sections describe some differences between the traditional
NI-488.2 calls and the multi-device NI-488.2 calls.

Communicating with a Single GPIB Device

If your system hasonly one deviceattached to each interface, thetraditional
NI-488.2 calls are probably sufficient for your programming needs. A
typical NI-488.2 application with a single device has three phases:

e Initialization: usei bdev to get ahandle and usei bcl r to clear the
device.

e Device Communication: usei bwt,ibrd,ibtrg,ibrsp,and
i bwai t to communicate with the device.

e Cleanup: usei bonl to put the handle offline.

Refer to the sample applications that are installed with the N1-488.2
software to see detailed examples for different GPIB device types.

For NI-488.2 applications that need to control the GPIB in non-typical
ways, for example, to communicate with non-compliant GPIB devices,
there are a set of low-level functions that perform rudimentary GPIB
applications. If you use these functions, you need to understand GPIB
management details like how to address talkers and listeners. Refer to
Appendix A, GPIB Basics, for some details on GPIB management.

The set of low-level functions are called board-level functions. They access
the interface directly and require you to handle the addressing and bus
management protocol. These functions give you the flexibility and control
to handle situations such as the following:

e Communicating with non-compliant (non-1EEE 488.2) devices.
e Altering various low-level interface configurations.
¢ Managing the bus in non-typical ways.
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Board-level functions that an NI-488.2 application might use include the
following—i becnd, i brd,i bwt,andi bconfi g. For adetailed list, refer
to the N1-488.2 online help. For instructions on accessing the online help,
refer to the Using the NI-488.2 Documentation section in About This
Manual.

Using Multiple Interfaces and/or Multiple Devices

When your system includes an interface that must access multiple devices,
use the multi-device N1-488.2 calls, which can perform the following tasks
with asinglecall:

e Findthe Listeners on the bususing Fi ndLst n.

» Find adevice requesting service using Fi ndRQS.

« Determine the state of the SRQ line, or wait for SRQ to be asserted
using Test SRQOr Wi t SRQ.

e Address multiple devices to receive acommand using SendLi st .

You can mix board-level traditional NI1-488.2 calls with the multi-device
NI-488.2 calls to have access to all the NI-488.2 functionality.

Checking Status with Global Variables

Each NI-488.2 API call updatesfour global variablesto reflect the status of
the device or interface that you are using. These global status variables are
the status word (i bst a), the error variable (i ber r), and the count
variables (i bent andi bent |). They contain useful information about the
performance of your application. Y our application should check these
variables after each NI-488.2 call. The following sections describe each of
these global variables and how you can use them in your application.

@ Note If your application is amultithreaded application, refer to the section Writing
Multithreaded Win32 NI-488.2 Applications in Chapter 7, NI-488.2 Programming
Techniques.

Status Word (ibsta)

All NI1-488.2 calls update aglobal statusword, i bst a, which contains
information about the state of the GPIB and the GPIB hardware. The value
stored ini bst a isthereturn value of all the traditional NI1-488.2 calls,
excepti bf i nd andi bdev. You can examine various status bitsini bst a
and use that information to make decisions about continued processing. If
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you check for possible errors after each call using thei bst a ERR bit,
debugging your application is much easier.

i bst a isa16-bit value. A bit value of one (1) indicates that a certain
condition isin effect. A bit value of zero (0) indicates that the condition is
not in effect. Each bit ini bst a can be set for device-level traditional
NI-488.2 calls (dev), board-level traditional NI1-488.2 calls and
multi-device NI-488.2 calls (brd), or al (dev, brd).

Table 3-1 shows the condition that each hit position represents, the bit
mnemonics, and the type of callsfor which the bit can be set. For adetailed
explanation of each status condition, refer to Appendix B, Satus Word

Conditions.
Table 3-1. Status Word Layout
Bit Hex

Mnemonic Pos | Value Type Description
ERR 15 8000 | dev, brd NI-488.2 error
TIMO 14 4000 | dev, brd Time limit exceeded
END 13 2000 | dev, brd END or EOS detected
SRQI 12 1000 | brd SRQ interrupt received
RQS 11 800 | dev Device requesting

service

CMPL 8 100 dev, brd 1/0 completed
LOK 7 80 brd Lockout State
REM 6 40 brd Remote State
CiC 5 20 brd Controller-In-Charge
ATN 4 10 brd Attention is asserted
TACS 3 8 brd Talker
LACS 2 4 brd Listener
DTAS 1 2 brd Device Trigger State
DCAS 0 1 brd Device Clear State
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The language header file defines each of thei bst a statusbits. You can test
for ani bst a status bit being set using the bitwise and operator (&in
C/C++). For example, thei bst a ERR bit ishit 15 of i bst a.

To check for an NI-488.2 error, use the following statement after each
NI-488.2 call:

if (ibsta & ERR
printf("N-488.2 error encountered");

Error Variable (iberr)

If the ERR bitissetini bst a, an NI-488.2 error has occurred. When an
error occurs, theerror typeisspecified by i ber r . To check for an NI1-488.2
error, use the following statement after each NI-488.2 call:

if (ibsta & ERR)
printf("N-488.2 error %l encountered", iberr);

@ Note Thevalueini berr ismeaningful asan error type only when the ERR bitisset in
i bst a, indicating that an error has occurred.

For more information about error codes and solutions, refer to Chapter 4,
Debugging Your Application, or Appendix C, Error Codes and Solutions.

Count Variables (ibcnt and ibcntl)

The count variables are updated after each read, write, or command
function. In Win32 applications, i bcnt andi bent | are 32-bit integers.
On some systems, like MS-DOS, i bent isal16-bitinteger, andi bent | is
a 32-bit integer. For cross-platform compatibility, all applications should
usei bent | . If you are reading data, the count variables indicate the
number of bytesread. If you are sending data or commands, the count
variables reflect the number of bytes sent.

Using Interactive Control to Communicate with Devices

Before you begin writing your application, you might want to use the
Interactive Control utility to communicate with your instruments
interactively by typing in commandsfrom the keyboard rather than from an
application. Y ou can use the Interactive Control utility to learn to
communicate with your instruments using the NI-488.2 API. For specific
device communication instructions, refer to the user manual that camewith
your instrument. For information about using the Interactive Control utility
and detailed examples, refer to Chapter 6, Interactive Control Utility.

© MNational Instruments Corporation 3-7 NI-488.2 User Manual for Windows



Chapter 3 Developing Your NI-488.2 Application

Programming Models

Applications That Communicate with a Single GPIB Device

This section describes items you should include in your application and
provides general program steps with an NI-488.2 example.

Items to Include
Include the following itemsin your application:

e Header files—In aC application, include the header fileswi ndows. h
and decl - 32. h. The standard Windows header file, wi ndows. h,
contains definitions used by decl - 32. h, and decl - 32. h contains
prototypesfor the NI-488.2 callsand constantsthat you can usein your
application.

e Error checking—Check for errors after each NI-488.2 call.

e Error handling—Declare and define a function to handle NI1-488.2
errors. Thisfunction takesthe device offline and closesthe application.
If the function is declared as:

voi d gpiberr (char * msg); /*function prototype*/
Then, your application invokes it as follows:

if (ibsta & ERR) {
gpi berr ("Nl -488.2 error");
}

General Program Steps and Examples

The following steps show you how to use the device-level traditional
NI-488.2 callsin your application. The NI-488.2 software includes the
source codefor an examplewrittenin C, devquer y. c, and the source code
for the example written to use direct entry to access gpi b-32.dl |,

dl I devquery. c. The NI-488.2 software a so includes a sample program
written in Visual Basic, devquery. frm

Initialization

Step 1. Open a Device

Usei bdev to open adevice handle. Thei bdev function requires the
following parameters:

e Connect board index (typically 0, for GPI BO).

e Primary address for the GPIB instrument (refer to the instrument user
manual or use the Fi ndLst n function to dynamically determine the
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GPIB address of your GPIB device, asdescribed in Sep 2. Determine
the GPIB Address of Your Devicein the section Applications That Use
Multiple Interfaces or Communicatewith Multiple GPIB Deviceslater
in this chapter).

*  Secondary address for the GPIB instrument (0 if the GPIB instrument
does not use secondary addressing).

e Timeout period (typically set to T10s, which is 10 seconds).

»  End-of-transfer mode (typically set to 1 sothat EOI isasserted with the
last byte of writes).

»  EOS detection mode (typically 0 if the GPIB instrument does not use
EOS characters).

A successful i bdev call returns a device handle, ud, that is used for all
device-level traditional NI-488.2 calls that communicate with the GPIB
instrument.

Step 2. Clear the Device

Usei bel r toclear thedevice. Thisresetsthe device sinterna functionsto
the default state.

Device Communication

Step 3. Communicate with the Device

Communicate with the device by sending it the " * I DN?" query and then
reading back the response. Many devicesrespond to thisquery by returning
adescription of the device. Refer to the documentation that came with your
GPIB deviceto see specificinstructions on the proper way to communicate
with it.

Step 3a.
Usei bwrt tosendthe"*I DN?" query command to the device.

Step 3b.
Usei br d to read the response from the device.

Continue communicating with the GPIB device until you are finished.

Cleanup

Step 4. Place the Device Offline before Exiting Your Application
Usei bonl to put the device handle offline before you exit the application.
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Applications That Use Multiple Interfaces or Communicate with
Multiple GPIB Devices

This section describes items you should include in your application and
provides general program steps with an NI-488.2 example.

Items to Include
Include the following itemsin your application:

e Header files—In aC application, include the header fileswi ndows. h
and decl - 32. h. The standard Windows header file, wi ndows. h,
contains definitions used by decl - 32. h, and decl - 32. h contains
prototypesfor the NI-488.2 callsand constantsthat you can usein your
application.

e Error checking—Check for errors after each NI-488.2 call.
e Error handling—Declare and define a function to handle NI1-488.2

errors. Thisfunction takesthe device offline and closesthe application.
If the function is declared as:

voi d gpiberr (char * msg); /*function prototype*/
Then your application invokesit as follows:
if (ibsta & ERR) {
gpi berr ("Nl -488.2 error");
}

General Program Steps and Examples

The following steps show you how to use the multi-device NI-488.2 calls
in your application. The NI-488.2 software includes the source code for an
examplewrittenin C, 4882quer y. ¢, and the source code for the example
written to usedirect entry to accessthegpi b- 32. dl | ,dl | 4882query. c.
The NI-488.2 software also includes a sample program written in Visual
Basic, query4882. frm

Initialization

Step 1. Become Controller-In-Charge (CIC)

Use SendI FCto initialize the bus and the GPIB interface so that the GPIB
interfaceis Controller-In-Charge (CIC). The only argument of Sendl FCis
the GPIB interface number, typically O for GPI BO.
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Step 2. Determine the GPIB Address of Your Device

UseFi ndLst n tofind all the devices attached to the GPIB. TheFi ndLst n
function requires the following parameters:

» Interface number (typically 0, for GPI BO).
e Alist of primary addresses, terminated with the NOADDR constant.

e Alistfor reported GPIB addresses of devices found listening on the
GPIB.

e Limit, which isthe number of the GPIB addresses to report.

Use Fi ndLst n to test for the presence of all of the primary addresses that
arepassed toit. If adevice is present at a particular primary address, then
the primary addressis stored in the GPIB addresses list. Otherwise, all
secondary addresses of the given primary address are tested, and the GPIB
address of any devices found are stored in the GPIB addresses list. When
you have the list of GPIB addresses, you can determine which one
corresponds to your instrument and use it for subsequent calls.

Alternately, if you already know your GPIB device's primary and
secondary address, you can create an appropriate GPIB addressto usein
subsequent NI-488.2 calls, asfollows. aGPIB addressisa 16-bit value that
contains the primary addressin the low byte and the secondary addressin
the high byte. If you are not using secondary addressing, the secondary
addressis 0. For example, if the primary addressis 1, then the 16-bit value
is0x01; otherwise, if the primary addressis 1 and the secondary addressis
0x67, then the 16-bit value is 0x6701.

Step 3. Initialize the Devices

Use Devd ear Li st to clear the devices on the GPIB. The first argument
isthe GPIB interface number. The second argument isthe list of GPIB
addresses that were found to be listening as determined in Step 2.

Device Communication

Step 4. Communicate with the Devices

Communicate with the devices by sending them the" * | DN?" query and
then reading back the responses. Many devices respond to this query by
returning adescription of the device. Refer to the documentation that came
with your GPIB devices to see specific instruction on the proper way to
communicate with them.
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Step 4a.

Use SendLi st to sendthe" * | DN?" query command to multiple GPIB
devices. The addressis the list of GPIB devices to be queried. The buffer
that you passto SendLi st isthe command message to the device.

Step 4b.
Use Recei ve for each device to read the responses from each device.

Continue communicating with the GPIB devices until you are finished.

Cleanup

Step 5. Place the Interface Offline before Exiting Your Application
Usei bonl to put the interface offline before you exit the application.

Language-Specific Programming Instructions

The following sections describe how to develop, compile, and link your
Win32 NI-488.2 applications using various programming languages.

Microsoft Visual C/C++ (Version 2.0 or Later)

Before you compile your Win32 C application, make sure that the
following lines are included at the beginning of your program:

#i ncl ude <wi ndows. h>
#i ncl ude "decl-32. h"

To compile and link a Win32 console application named cpr og inaDOS
shell, type the following on the command line:

cl cprog.c gpib-32. obj

Borland C/C++ (Version 4.0 or Later)

Before you compile your Win32 C application, make sure that the
following lines are included at the beginning of your program:

#i ncl ude <wi ndows. h>
#i ncl ude "decl-32. h"

To compile and link a Win32 console application named cpr og in aDOS
shell, type the following on the command line:

bcc32 -w32 cprog. ¢ borl andc_gpi b- 32. obj
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Visual Basic (Version 4.0 or Later)

With Visual Basic, you can access the traditional NI-488.2 calls as
subroutines, using the BASIC keyword CALL followed by the traditional
NI-488.2 call name, or you can access them using thei | set of functions.
With some of the NI-488.2 calls (for examplei br d and Recei ve), the
length of the string buffer is automatically cal culated within the actual
function or subroutine, which eliminates the need to passin the length as
an extraparameter. For more information about function syntax for Visual
Basic, refer to the NI-488.2 online help. For instructions on accessing the
online help, refer to the Using the NI-488.2 Documentation sectionin
About This Manual.

Before you run your Visual Basic application, includetheni gl obal . bas
and vbi b- 32. bas filesin your application project file.

Direct Entry with C

The following sections describe how to use direct entry with C.

gpib-32.dll Exports

gpi b- 32. dl | exports pointersto the global variables and al of the
NI-488.2 calls. Pointers to the global variables (i bst a, i berr, i bent,
andi bent | ) are accessible through these exported variables:

int *user_ibsta,;

int *user_iberr;

int *user_ibcnt;

| ong *user_ibcntl;

Except for the functionsi bbna, i bfi nd,i brdf,andi bwtf,all

the NI-488.2 call names are exported from gpi b- 32. dI | . Thus, to use
direct entry to access a particular function and to get a pointer to the
exported function, you just need to call Get Pr ocAddr ess passing the
name of the function as a parameter. For more information about the
parameters to use when you invoke the function, refer to the NI1-488.2
online help. For instructions on accessing the online help, refer to the
Using the NI-488.2 Documentation section in About This Manual.

The functionsi bbna, i bfind,i brdf,andi bwtf al requirean
argument that isaname. i bbna requires an interface name, i bf i nd
requires an interface or devicename, andi br df andi bwrt f requireafile
name. Because Windows 2000/NT supports both normal (8-bit) and
Unicode (16-bit) characters, gpi b- 32. dI | exports both normal and
Unicode versions of these functions. Because Windows 98/95 does not
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support 16-bit wide characters, use only the 8-bit ASCII versions, named
i bbnaA, i bfindA,ibrdf A andi bwtf A The Unicode versions are
named i bbnaWi bf i ndwWi br df wand i bwr t f WYou can use either the
Unicode or ASCII versions of these functions with Windows 2000/NT, but
only the ASCII versions with Windows 98/95.

In addition to pointers to the status variables and a handle to the loaded
gpi b- 32. dI | , you must define the direct entry prototypes for the
functionsyou usein your application. For the prototypes for each function
exported by gpi b- 32. dI |, refer to the NI-488.2 online help. For
instructions on accessing the online help, refer to the Using the NI-488.2
Documentation section in About This Manual.

The direct entry sample programs illustrate how to use direct entry to
accessgpi b- 32. dI | . For moreinformation about direct entry, refer to the
online help for your development environment.

Directly Accessing the gpib-32.dll Exports

Make sure that the following lines are included at the beginning of your
application:

#i fdef __cplusplus
extern "C'{
#endi f

#i ncl ude <wi ndows. h>
#i ncl ude "decl-32. h"

#i fdef __cplusplus

}
#endi f

In your Win32 application, you need to load gpi b- 32. dI | before
accessing the gpi b- 32. dI | exports. The following code fragment shows
you how to call the LoadLi br ary function to load gpi b- 32. dI | and
check for an error:

H NSTANCE Gpi b32Li b = NULL;
Gpi b32Li b=LoadLi brary("GPl B-32. DLL");
if (Gpib32Lib == NULL) {
return FALSE;
}
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For the prototypes for each function, refer to the N1-488.2 online help. For
instructions on accessing the online help, refer to the Using the NI-488.2
Documentation section in About This Manual.

For functionsthat return an integer value, likei bdev ori bwr t , the pointer
to the function needs to be cast as follows:

int (_stdcall *Pnane)

where * Pname isthe name of the pointer to the function. For functionsthat
do not return avalue, like Fi ndLst n or SendLi st , the pointer to the
function needs to be cast as follows:

void (_stdcall *Pnane)

where* Pname isthe name of the pointer to thefunction. They arefollowed
by thefunction’slist of parametersas described inthe NI-488.2 online hel p.
For instructions on accessing the online help, refer to the Using the
NI-488.2 Documentation section in About This Manual.

Following is an example of how to cast the function pointer and how the
parameter list isset up for i bdev andi bonl functions:

int (_stdcall *Pibdev)(int ud, int pad, int sad, int tno,
int eot, int eos);

int (_stdcall *Pibonl)(int ud, int v);

Next, your Win32 application needs to use Get Pr ocAddr ess to get the
addresses of the global status variables and functions your application
needs. The following code fragment shows you how to get the addresses of
the pointers to the status variables and any functions your application
needs:

/* Pointers to NI -488.2 global status variables */
int *Pi bsta;
int *Pi berr;
| ong *Pi bentl;
static int(__stdcall *Pibdev)
(int ud, int pad, int sad, int tno, int eot,
int eos);

static int(__stdcall *Pibonl)
(int ud, int v);
Pibsta = (int *) GetProcAddress(Gpi b32Li b,
(LPCSTR) "user _i bsta");
Piberr = (int *) GetProcAddress(Gpi b32Li b,
(LPCSTR) "user _i berr");
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Pi bcntl = (long *) GetProcAddress(Goi b32Li b,
(LPCSTR) "user _i bcnt");

Pi bdev = (int (__stdcall *)

(int, int, int, int, int, int))

Get ProcAddr ess( Gpi b32Li b, (LPCSTR)"i bdev");
Pibonl = (int (__stdcall *)(int, int))
Get ProcAddr ess( Gpi b32Li b, (LPCSTR)"ibonl");

If Get ProcAddr ess fails, it returnsaNULL pointer. The following
code fragment shows you how to verify that none of the callsto
Get Pr ocAddr ess failed:

if ((Pibsta == NULL) ||
(Piberr == NULL) ||
(Pibcntl == NULL) ||
(Pibdev == NULL) ||
(Pibonl == NULL)) {

/* Free the GPIB library */
FreeLi brary(Gpi b32Li b) ;
printf("GetProcAddress failed.");

}

Your Win32 application needs to dereference the pointer to access either
the status variables or function. The following code shows you how to call
afunction and access the status variable from within your application:

dvm = (*Pi bdev) (0, 1, 0, Ti0s, 1, 0);
if (*Pibsta & ERR) {

printf("Call failed");
}

Before exiting your application, you need to free gpi b- 32. dI | with the
following command:

Fr eeLi brary( Goi b32Li b) ;

For more examples of directly accessing gpi b- 32. dlI | , refer to the direct
entry sample programsdl | devquery. c anddl | 4882query. c, installed
with the N1-488.2 software. For more information about direct entry, refer
to the online help for your development environment.
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Running Existing NI-488.2 Applications

Running Existing Win32 and Win16 NI-488.2 Applications

The NI-488.2 software includes the necessary components to allow
existing Win32 and Win16 NI-488.2 applications to run properly.

Running Existing DOS NI-488.2 Applications Under Windows 98/95

To configure the NI-488.2 software to run existing DOS NI-488.2
applications, complete the following steps:

1. Makesurethat no older version of the NI-488.2 DOS device driver is
being loaded from your conf i g. sys file. To do so, complete the
following steps:

a Locateyour confi g. sys fileand open it for editing.
b. Findthefollowing line:
devi ce=<pat h>\ gpi b. com

where <pat h> refersto the drive and directory where gpi b. com
islocated.

c. If that line appears, type REMat the beginning of theline, as
follows:

REM devi ce=<pat h>\ gpi b. com
d. Saveyour confi g. sys fileand closeit.

2. Select Start»Programs»National | nstruments NI1-488.2»Explore
GPIB to start Measurement & Automation Explorer.

3. ExpandtheDevicesand I nterfacesdirectory by clicking onthe + next
to the folder.

4. Select your GPIB interface and select T ool s»Settings»NI-488.2 from
the Explorer menu.

5. Enable or disable DOS support in the NI-488.2 Settings dialog box
and click on the OK button.

6. If you are prompted to do so, restart your system.
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Running Existing DOS NI-488.2 Applications under Windows 2000/NT

To run DOS NI-488.2 applications, you must enable NI-488.2 DOS
support under Windows 2000/NT. To enable NI1-488.2 DOS support in
Windows 2000/NT, complete the following steps:

1. Openyourconfig. nt file located in the Windows 2000/NT
system32 directory (for example, c: \ wi ndows\ syst enB2).

2. Find thefollowing lines:
REM ***To run DOS GPI B applications, unconment the
REM ***f ol | owi ng |ine

REM devi ce=<pat h>\ doswi n16\ gpi b-nt.com

where <pat h> isthe directory in which you installed the NI1-488.2
software.

3. Remove REMfrom the last line so that it reads as follows:
devi ce=<pat h>\ doswi n16\ gpi b-nt. com

To disable DOS support, add REMback to the line where it was removed.
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This chapter describes several ways to debug your application.

NI Spy

The NI Spy utility monitors NI1-488.2 API calls made by NI-488.2
applications. It records NI-488.2 APl input and output values from all
Win32, Winl6, and DOS NI-488.2 applications.

To start NI Spy, complete the following steps:

1. Select Start»Programs»National I nstruments NI-488.2»Explore
GPIB to start Measurement & Automation Explorer.

2. ExpandtheDevicesand I nterfacesdirectory by clicking onthe + next
to the folder.

3. Right-click on your GPIB interface and select NI Spy from the
drop-down menu that appears.

4. OntheNI Spy toolbar, click on the blue arrow button to start acapture.
5. Start the NI-488.2 application that you want to monitor.
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NI Spy recordsand displaysall NI-488.2 calls, as shown in Figure 4-1.

% NI Spy - [capture on] =] E3
File Edit Wiew Spy Help

|| 2] #) 2|0 =] %] %

Mumber | GRIE Calls ihzta iberr ikt Time

1 ihdlew(0, 3, 0 (0x0), T10= (13), 1, 0x0000) 00100 i} 00000 12:53:05.496

2 ibcirUD) 00100 1} 00000 12:53:07 378

3 ibertIDD, "N, S (0x5)) 00100 i} 00005

4 " R (0x337) 02100 u] 00033 X
i 5 11 (0xB7) 0x0100 i 0000k 0.

B , L8 (0x80) 00100 i} 0x0003 153

7 ibrd(LUD0, "0.9453E2.", 9 (0x49)) 02100 i} 0x0009 12:53:56.158

/] |+
For Help, press F1 |Captured: 7, Displayed: ¥ v

Figure 4-1. NI-488.2 Calls Recorded by NI Spy

For more information about using NI Spy, select Help»Help Topicsin
NI Spy or refer to Chapter 5, NI Spy Utility.

Global Status Variables

NI-488.2 User Manual for Windows

At the end of each NI-488.2 call, the global status variables (i bst a,

i berr,ibcnt,andi bcnt ) are updated. If you are developing an
NI-488.2 application, you should check for errors after each N1-488.2 call.
If aNI-488.2 call failed, the high bit of i bst a (the ERR bit) is set. For a
failed NI-488.2 call, i berr containsavaluethat definesthe error. In some
error cases, thevalueini bent | contains even more error information.

You can use NI Spy to determine which NI-488.2 call isfailing. Once you
know which NI-488.2 call fails, refer to Appendix B, Satus Word
Conditions, and Appendix C, Error Codes and Solutions, for help
understanding why the NI1-488.2 call failed. Thisinformation is aso
available in the NI1-488.2 online help. For instructions on accessing the
online help, refer to the Using the NI-488.2 Documentation section in
About This Manual.
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Existing Applications

If the application does not have built-in error detection handling, you can
use NI Spy to determine which NI-488.2 call isfailing.

To start NI Spy, refer to the NI Spy section earlier in this chapter.

After you have an NI Spy capture file, you can use NI Spy to search for
failed NI-488.2 calls by searching for callswith the ERR bit set. Once you
know which NI-488.2 call fails, refer to Appendix B, Satus Word
Conditions, and Appendix C, Error Codes and Solutions, for help
understanding why the N1-488.2 call failed. Thisinformation is also
available in the NI-488.2 online help. For instructions on accessing the
online help, refer to the Using the NI-488.2 Documentation sectionin
About This Manual.

NI-488.2 Error Codes

The error variable is meaningful only when the ERR bit in the status
variable, i bst a, isset. For adetailed description of each error and possible
solutions, refer to Appendix C, Error Codes and Solutions.

Configuration Errors

Severa applications require customized configuration of the NI1-488.2
driver. For example, you might want to terminate reads on a special
end-of-string character, or you might require secondary addressing. In
these cases, you can either reconfigure from your application using the
i bconf i g function or reconfigure using the NI-488.2 Configuration
utility.

@ Note Nationa Instruments recommends usingi bconf i g to modify the configuration.

If your application usesi bconf i g, it works properly regardless of the
previous configuration. For moreinformation about usingi bconf i g, refer
to the description of i bconf i g in the NI-488.2 online help. For
instructions on accessing the online help, refer to the Using the NI-488.2
Documentation section in About This Manual.
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Timing Errors

If your application fails, but the same callsissued interactively in the
Interactive Control utility are successful, your program might be issuing
the NI-488.2 calls too quickly for your device to process and respond to
them. This problem can also result in corrupted or incomplete data. This
should only be a problem with older, non-standard GPIB devices.

To check if your interactively issued NI-488.2 calls succeed, use the
Interactive Control utility. To start the Interactive Control utility, complete
the following steps:

1. Select Start»Programs»National Instruments NI-488.2»Explore
GPI B to start Measurement & Automation Explorer.

2. Expandthe Devicesand I nterfacesdirectory by clicking onthe + next
to the folder.

3. Right-click on your GPIB interface and select Interactive Control
from the drop-down menu that appears.

4. At the command prompt, type NI-488.2 API calls to communicate
interactively with the your instrument. For example, you might use
i bdev,ibclr,ibwt,ibrd,andibonl .

Toview theonline help for Interactive Control, type hel p at the Interactive
Control command prompt.

A well-behaved | EEE 488 device does not experiencetiming errors. If your
deviceisnot well-behaved, you can test for and resolve the timing error by
single-stepping through your program and inserting finite delays between
each NI-488.2 call. Oneway to do thisisto have your device communicate
its status whenever possible. Although this method is not possible with
many devices, itisusually the best option. Your delaysare controlled by the
device and your application can adjust itself and work independently on
any platform. Other delay mechanisms probably exhibit differing behaviors
on different platforms and thus might not eliminate timing errors.
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Communication Errors

Repeat Addressing

The following sections describe communication errors you might
encounter in your application.

Devicesadhering to the IEEE 488.2 standard should remainin their current
state until specific commands are sent across the GPIB to change their
state. However, some devices require GPIB addressing before any GPIB
activity. Therefore, you might need to configure your NI-488.2 driver to
perform repeat addressing if your device does not remain in its currently
addressed state. Y ou can either reconfigure from your application using

i bconfi g, or reconfigure using the NI-488.2 Configuration utility.

@ Note National Instruments recommendsusingi bconf i g to modify the configuration.

If your application usesi bconf i g, it works properly regardless of the
previous configuration. For moreinformation abouti bconf i g, refer tothe
description of i bconfi g inthe NI-488.2 online help. For instructions on
accessing the online help, refer to the Using the NI-488.2 Documentation
section in About This Manual.

Termination Method

Other Errors

Y ou should be aware of the datatermination method that your device uses.
By default, your NI-488.2 softwareis configured to send EOI on writesand
terminate reads on EQI or a specific byte count. If you send a command
string to your device and it does not respond, it might not be recognizing
the end of the command. In that case, you need to send atermination
message, such as <CR> <LF>, after awrite command, as follows:

i bwt (dev, " COMVAND\ xOA\ x0D", 9) ;

If you experience other errorsin your application, refer to the N1-488.2
online help. It includes extensive troubleshooting information and the
answers to frequently asked questions. For instructions on accessing the
online help, refer to the Using the NI-488.2 Documentation section in
About This Manual.
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NI Spy Utility

This chapter introduces you to NI Spy, a utility that monitors and records
multiple National Instruments APIs (for example, NI-488.2 and VISA).

Overview

NI Spy monitors, records, and displays the NI1-488.2 calls made from
Win32, Winl16, and DOS NI-488.2 applications. It is auseful tool for
troubleshooting errorsin your application and for verifying that the
communication with your GPIB instrument is correct.

Starting NI Spy

To start NI Spy, complete the following steps:

1. Select Start»Programs»National Instruments NI-488.2»Explore
GPIB to start Measurement & Automation Explorer.

2. ExpandtheDevicesand I nterfacesdirectory by clicking onthe + next
to the folder.

3. Right-click on your GPIB interface and select NI Spy from the
drop-down menu that appears.

Onthe NI Spy toolbar, click on the blue arrow button to start a capture.
5. Start the NI-488.2 application that you want to monitor.
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NI Spy Utility

NI Spy recordsand displaysall NI-488.2 calls, asshown in Figure 5-1.

% NI Spy - [capture on] =] E3
File Edit Wiew Spy Help

|| 2] #) 2|0 =] %] %

Mumber | GRIE Calls ihzta iberr ikt Time

1 ihdlew(0, 3, 0 (0x0), T10= (13), 1, 0x0000) 00100 i} 00000 12:53:05.496

2 ibcirUD) 00100 1} 00000 12:53:07 378

3 ibertIDD, "N, S (0x5)) 00100 i} 00005

4 " R (0x337) 02100 u] 00033
i 5 11 (0xB7) 0x0100 i 0000k

B , L8 (0x80) 00100 i} 0x0003 153

7 ibrd(LUD0, "0.9453E2.", 9 (0x49)) 02100 i} 0x0009 12:53:56.158

/] |+
For Help, press F1 |Captured: 7, Displayed: ¥ v

Figure 5-1. NI-488.2 Calls Recorded by NI Spy

Using the NI Spy Online Help

To view the built-in, context-sensitive online help for the NI Spy utility,
select Help»Help Topicsin NI Spy. Y ou can also view the online help by
clicking on the question mark button on the NI Spy toolbar, and then
clicking on the area of the screen about which you have a question.

Locating Errors with NI Spy

All NI-488.2 calls returned with an error are displayed in red within the
main NI Spy window.

Viewing Properties for Recorded Calls

To see the detailed properties of any call recorded in the main NI Spy
window, double-click on the call. The Call Properties window appears.
It contains general, input, output, and buffer information.
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Exiting NI Spy

When you exit NI Spy, its current configuration is saved and used to
configure NI Spy when you start it again. Unlessyou savethe data captured
in NI Spy before you exit, that information islost.

To save the captured data, click on the red circled X button on the toolbar
and select File»Save Asto savethedatain a. spy file. After you save your
data, select File»Exit to exit the NI Spy utility.

Performance Considerations

NI Spy can slow down the performance of your NI-488.2 application, and
certain configurations of NI Spy have alarger impact on performance than
others. For example, configuring NI Spy to record callsto an output file or
to use full buffers might have a significant impact on the performance of
both your application and your system. For this reason, use NI Spy only
while you are debugging your application or in situations where
performanceis not critical.
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Interactive Control Utility

This chapter introduces you to the Interactive Control utility, which lets
you communicate with GPIB devices interactively.

Overview

With the Interactive Control utility, you communicate with the GPIB
devices through functions you interactively type in at the keyboard. For
specific information about communicating with your particular device,
refer to the documentation that came with the device. Y ou can use the
Interactive Control utility to practice communication with the instrument,
troubleshoot problems, and develop your application.

The Interactive Control utility helpsyou tolearn about your instrument and
to troubleshoot problems by displaying the following information on your
screen after you enter a command:

Results of the statusword (i bst a) in hexadecimal notation.
Mnemonic constant of each bit setini bst a.

Mnemonic value of the error variable (i ber r) if an error exists
(the ERR bitissetini bst a).

Count value for each read, write, or command function.
Data received from your instrument.

Getting Started with Interactive Control

This section shows you how to use the Interactive Control utility to test a
seguence of NI-488.2 calls.

To start the Interactive Control utility, complete the following steps:

1.

© MNational Instruments Corporation

Select Start»Programs»National | nstruments NI-488.2»Explore
GPIB to start Measurement & Automation Explorer.

Expand the Devicesand | nter facesdirectory by clicking onthe + next
to the folder.
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3. Right-click on your GPIB interface and select I nteractive Control
from the drop-down menu that appears.

For help on any Interactive Control command, type hel p followed by
the command. For example, typehel p i bdev or hel p set.

4. Open either an interface handle or device handle to use for further
NI-488.2 calls. Usei bdev to open adevice handle, i bf i nd to open
an interface handle, or theset 488. 2 command to switchto a
488.2 prompt.

The following example usesi bdev to open adevice, assignsit to
access interface gpi b0, chooses a primary address of 6 with no
secondary address, sets atimeout of 10 seconds, enables the END
message, and disables the EOS mode:
1 i bdev

enter board index: 0

enter prinary address: 6

enter secondary address: O

enter timeout: 13

enter ‘EA on last byte' flag: 1

enter end-of-string node/byte: 0

udo:

@ Note If you type acommand and no parameters, Interactive Control prompts you for the
necessary arguments. If you aready know the required arguments, you can type them at
the command prompt, as follows:

:ibdev 0 6 013 1 0
udo:

@ Note If you do not know the primary and secondary address of your GPIB instrument,
right-click on your GPIB interface in Measurement & Automation Explorer and select
Scan for Instruments. After Explorer scans your interface, it displays your instrument
addressin the right window pane. The instrument shown in Figure 6-1 has a primary
address of 1 and no secondary address.

I arme | Type | alle | D ezcription
Inztrument]  FLUKE, 45, 4790173.1.601.0 PAD =1  GPIB Instrument

Figure 6-1. Instrument Address in Measurement & Automation Explorer
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After you successfully complete i bdev, you have aud prompt. The
new prompt, udo, represents adevice-level handle that you can usefor
further NI-488.2 calls. To clear the device, usei bcl r, asfollows:

udo: i bclr
[0100] (cmpl)
Towritedatato the device, usei bwr t . Make surethat you refer to the
documentation that came with your GPIB instrument for recognized
command messages.
udO: i bwt
enter string: "*|DN?"
[0100] (cnpl)
count: 5
Or, equivalently:
udO: ibwrt "*IDN?"
[0100] (cnpl)
count: 5
Toread datafromyour device, usei br d. Thedatathat isread fromthe
instrument is displayed. For example, to read 29 bytes, enter the
following:
udO: ibrd
enter byte count: 29
[0100] (cnpl)

count: 29

46 4C 55 4B 45 2C 20 34 FLUKE, 4
35 2C 20 34 37 39 30 31 5, 47901
37 33 2C 20 31 2E 36 20 73, 1.6
44 31 2E 30 OA D. 10.

Or, equivalently:

udO: ibrd 29

[0100] (cnpl)

count: 29

46 4C 55 4B 45 2C 20 34 FLUKE, 4
35 2C 20 34 37 39 30 31 5, 47901
37 33 2C 20 31 2E 36 20 73, 1.6
44 31 2E 30 OA D. 10.

When you finish communicating with the device, make sure you put it
offline using thei bonl command, as follows:

udOo: i bonl 0
[0100] (cnpl)
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Thei bonl command properly closes the device handle and the udo
prompt is no longer available.

9. To exit Interactive Control, type g.

Interactive Control Syntax

Number Syntax

String Syntax

The following special rules apply to making calls from the Interactive
Control utility:

e Theud or Boar dI d parameter isimplied by the Interactive Control
prompt, therefore it is never included in the call.

e Thecount parameter to functionsis unnecessary because buffer
lengths are automatically determined by Interactive Control.

«  Function return values are handled automatically by Interactive
Control. In addition to printing out the returni bst a value for the
function, it also prints other return values.

« If you do not know what parameters are appropriate to passto a given
function call, type in the function name and press <Enter>. The
Interactive Control utility then prompts you for each required
parameter.

Y ou can enter numbers in either hexadecimal or decimal format.

Hexadecimal numbers—You must prefix hexadecimal numbers with 0x.
For example, i bpad 0x16 setsthe primary address to 16 hexadecimal
(22 decimal).

Decimal numbers—Enter the number only. For example, i bpad 22 sets
the primary address to 22 decimal.

Y ou can enter stringsas an ASCII character sequence, hex bytes, or specia
symbols.

ASCII character sequence—You must enclose the entire sequence in
quotation marks.

Hex byte—You must use a backslash character and an x, followed by the
hex value. For example, hex 40 is represented by \ x40.
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Secial symbols—Some instruments require special termination or
end-of-string (EOS) characters that indicate to the device that a
transmission has ended. The two most common EOS charactersare\ r and
\'n.\ r represents a carriage return character and \ n represents a linefeed
character. You can use these special charactersto insert the carriage return
and linefeed charactersinto astring, asin"*1 DN?\ r\ n".

Some of the NI-488.2 calls have an address or address list parameter. An
addressisa 16-bit representation of the GPIB device address. The primary
addressis stored in thelow byte and the secondary address, if any, isstored
in the high byte. For example, adevice at primary address 6 and secondary
address 0x67 has an address of 0x6706. A NULL addressis represented as
Oxffff. An address list is represented by a comma-separated list of
addresses, such as 1, 2, 3.

Interactive Control Commands

Tables 6-1 and 6-2 summarize the syntax of the traditional NI-488.2 calls
in the Interactive Control utility. Table 6-3 summarizes the syntax of the
multi-device NI-488.2 callsin the Interactive Control utility. Table 6-4
summarizes the auxiliary functions that you can usein the Interactive
Control utility. For moreinformation about the function parameters, usethe
online help, available by typing in hel p. If you enter only the function
name, the Interactive Control utility prompts you for parameters.

Table 6-1. Syntax for Device-Level Traditional NI-488.2 Calls in Interactive Control

Syntax

Description

i bask option

Return configuration information where opt i on isamnemonic for a
configuration parameter

i bbna bname Change access interface of device where bnane is symbolic name of
new interface
i belr Clear specified device

i bconfig option
val ue

Alter configurable parameters where opt i on is mnemonic for a
configuration parameter

i bdev Bdl ndx pad
sad tno eot eos

Open an unused device; i bdev parameters are Bdl ndx pad sad tno
eot eos
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Table 6-1. Syntax for Device-Level Traditional NI-488.2 Calls in Interactive Control (Continued)

Syntax Description
i beos v Change/disable EOS message
i beot v Enable/disable END message
i bln pad sad Check for presence of device on the GPIB at pad, sad
i bl oc Gotolocd
i bonl v Place device online or offline
i bpad v Change primary address
i bpct Pass control
i bppc v Parallel poll configure
i brd count Read datawhere count isthe bytesto read
i brda count Read data asynchronously where count isthe bytesto read

i brdf flname

Read datato file where f | name is pathname of file to read

i brpp Conduct a paralel poll

i brsp Return serial poll byte

i bsad v Change secondary address

i bstop Abort asynchronous operation
ibtmo v Change/disable time limit
ibtrg Trigger selected device

i bwait mask

Wait for selected event where mask isahex or decimal integer or alist
of mask bit mnemonics, such asi bwait TI MO CMPL

i bwt wrtbuf

Write data

ibwta wtbuf

Write data asynchronously

ibwtf flnane

Write datafrom afile where f | name is pathname of file to write
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Table 6-2. Syntax for Board-Level Traditional NI-488.2 Calls in Interactive Gontrol

Syntax

Description

i bask option

Return configuration information where opt i on isamnemonic for
a configuration parameter

i bcac v Become active Controller
i bcnd cndbuf Send commands
i bcnda cndbuf Send commands asynchronously

i bconfig option
val ue

Alter configurable parameters where opt i on is mnemonic for a
configuration parameter

i bdma v Enable/disable DMA
i beos v Change/disable EOS message
i beot v Enable/disable END message

i bfi nd udnane

Return unit descriptor where udnane is the symbolic name of
interface (for example, gpi b0)

i bgts v Go from Active Controller to standby

i bist v Set/clear i st

i bli nes Read the state of al GPIB control lines

i bln pad sad Check for presence of device onthe GPIB at pad, sad

i bl oc Goto local

i bonl v Place device online or offline

i bpad v Change primary address

i bppc v Parallel poll configure

i brd count Read data where count isthe bytesto read

i brda count Read data asynchronously where count isthe bytesto read

i brdf flnane

Read datato file wheref | nane is pathname of file to read

i brpp Conduct a paralel poll

ibrsc v Request/release system control
ibrsv v Request service

i bsad v Change secondary address
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Table 6-2. Syntax for Board-Level Traditional NI-488.2 Calls in Interactive Control (Continued)

Syntax Description
i bsic Send interface clear
i bsre v Set/clear remote enable line
i bstop Abort asynchronous operation
ibtmo v Change/disable time limit
i bwait nask Wait for selected event where mask isahex or decimal integer or alist

of mask bit mnemonics, such asi bwait TI MO CVPL

i bwrt wrtbuf Write data

ibwta wtbuf

Write data asynchronously

ibwtf flnane

Write data from afile where f | name is pathname of file to write

Table 6-3. Syntax for Multi-Device NI-488.2 Calls in Interactive Gontrol

Syntax

Description

Al'l Spol | addrli st

Serial poll multiple devices

DevCl ear address

Clear adevice

DevCl ear Li st addrli st

Clear multiple devices

Enabl eLocal addrli st

Enable local control

Enabl eRenpt e addrli st

Enable remote control

FindLstn padlist limt Find all Listeners

Fi ndRQS addrl i st Find device asserting SRQ
PassControl address Pass control to adevice
PPol | Paralel poll devices

PPol | Confi g address dataline
| i neSense

Configure device for parallel poll

PPol | Unconfi g addrli st

Unconfigure device for parallel poll

RcvRespMsg count term nation

Receive response message

ReadSt at usByt e address

Serial poll adevice

Recei ve address count term nation

Receive data from adevice
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Table 6-3. Syntax for Multi-Device NI-488.2 Calls in Interactive Control (Continued)

Syntax

Description

Recei veSet up address

Receive setup

Reset Sys addrli st

Reset multiple devices

Send address buffer eotnode Send datato adevice
SendCmds buf f er Send command bytes
SendDat aByt es buffer eot node Send data bytes

Sendl FC

Send interface clear

SendLi st addrlist buffer eotnode

Send data to multiple devices

SendLLO

Put devicesin local |ockout

SendSet up addrli st

Send setup

Set RALS addrli st

Put devices in remote with lockout state

Test SRQ

Test for service request

Test Sys addrli st

Cause multiple devices to perform self-tests

Tri gger address

Trigger adevice

TriggerlList addrli st

Trigger multiple devices

Wi t SRQ Wait for service request
Table 6-4. Auxiliary Functions in Interactive Control
Function Description

set udnane

Select active device or interface where udnane is the symbolic name of the
new device or interface (for example, dev 1 or gpi b0). Call i bfi nd ori bdev
initially to open each device or interface.

set 488.2 v Start using multi-device NI1-488.2 calls for interface v.
hel p Display the Interactive Control utility online help.
hel p option Display help information about opt i on, where opt i on isany NI-488.2 or

auxiliary call (for example, hel p i bwrt or hel p set).

! Repeat previous function.

- Turn OFF display.
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Table 6-4. Auxiliary Functions in Interactive Control (Continued)

Function Description
+ Turn ON display.
n * function Execute function n timeswhere f unct i on represents the correct Interactive
Control function syntax.
n* | Execute previous function n times.
$ filenane Executeindirect file wheref i | enane is the pathname of afile that contains

Interactive Control functions to be executed.

buf fer option

Set type of display used for buffers. Valid optionsaref ul | , bri ef , asci i,
and of f . Defaultisful | .

q

Exit or quit.

Status Word

In the Interactive Control utility, all NI1-488.2 calls (except i bf i nd and

i bdev) return the statusword i bst a in two forms: a hex valuein square
bracketsand alist of mnemonicsin parentheses. In the following example,
the status word is on the second line, showing that the write operation
completed successfully:

udO: i bwt "*| DN?"
[ 0100] (cnpl)
count: 5

udo:

For moreinformation about i bst a, refer to Chapter 3, Developing Your
NI-488.2 Application.

Error Information

If an NI-488.2 call completes with an error, the Interactive Control utility
displays the relevant error mnemonic. In the following example, an error
condition EBUS has occurred during a data transfer:

udO: ibwt "*IDN?"
[8100] (err cnpl)

error: EBUS
count: 1
udo:
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In this exampl e, the addressing command bytes could not be transmitted to
the device. Thisindicatesthat either the GPIB device is powered off or the
GPIB cableis disconnected.

For adetailed list of the error codes and their meanings, refer to Chapter 4,
Debugging Your Application.

Count Information

When an I/O function compl etes, the Interactive Control utility displaysthe
actual number of bytes sent or received, regardless of the existence of an
error condition.

If one of the addressesin an addresslist isinvalid, then the error is EARG
and the Interactive Control utility displays the index of the invalid address
as the count.

The count has a different meaning depending on which NI-488.2 call is
made. For the correct interpretation of the count return, refer to thefunction
descriptions in the NI1-488.2 online help. For instructions on accessing the
online help, refer to the Using the NI-488.2 Documentation sectionin
About This Manual.
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This chapter describes techniques for using some NI-488.2 callsin your
application.

For more information about each function, refer to the NI1-488.2 online
help. For instructions on accessing the online help, refer to the Using the
NI-488.2 Documentation section in About This Manual.

Termination of Data Transfers

GPIB data transfers are terminated either when the GPIB EOI lineis
asserted with the last byte of atransfer or when a preconfigured
end-of-string (EOS) character is transmitted. By default, EQOI is asserted
with the last byte of writes and the EOS modes are disabled.

You canusethei beot functionto enableor disablethe end of transmission
(EOT) mode. If EOT modeisenabled, the GPIB EQI lineis asserted when
thelast byte of awriteis sent out on the GPIB. If itisdisabled, the EOI line
is not asserted with the last byte of awrite.

You can use thei beos function to enable, disable, or configure the EOS
modes. EOS mode configuration includes the following information:

e A 7-bit or 8-bit EOS byte.

»  EOS comparison method—T his indicates whether the EOS byte has
seven or eight significant bits. For a 7-bit EOS byte, the eighth bit of
the EOS byte isignored.

* EOS write method—If thisis enabled, the GPIB EOI lineis
automatically asserted when the EOS byteiswrittento the GPIB. If the
buffer passed into ani bwr t call contains five occurrences of the EOS
byte, the EQI lineis asserted as each of the five EOS bytes are written
tothe GPIB. If ani bwrt buffer does not contain an occurrence of the
EOS byte, the EQI lineis not asserted (unless the EOT modeis
enabled, in which case the EOI line is asserted with the last byte of
the write).
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e EOS read method—If thisisenabled, i brd, i br da, andi br df cals
are terminated when the EOS byte is detected on the GPIB, when the
GPIB EOQI lineis asserted, or when the specified count is reached. If
the EOS read method isdisabled, i brd, i brda, andi br df calls
terminate only when the GPIB EOQI lineis asserted or the specified
count has been read.

You can use thei bconf i g function to configure the software to indicate

whether the GPIB EOI line was asserted when the EOS byte wasread in.

Usethel bcEndBi t | sNor mal option to configure the software to report

only theEND bitini bst a when the GPIB EOI lineisasserted. By defaullt,
END isreported ini bst a when either the EOS byte isread in or the EOI
lineis asserted during a read.

High-Speed Data Transfers (HS488)

National Instruments has designed a high-speed data transfer protocol for
|EEE 488 called H$488. This protocol increases performance for GPIB
reads and writes up to 8 Mbytes/s, depending on your system.

H$SA488 is a superset of the IEEE 488 standard; thus, you can mix

|EEE 488.1, |EEE 488.2, and HS488 devicesin the same system. If HS488
is enabled, the TNT4882C hardware implements high-speed transfers
automatically when communicating with HS488 instruments. If you
attempt to enable HS488 on a GPIB interface that does not have the
TNT4882C hardware, the ECAP error code is returned.

Enabling HS488

To enable H$488 for your GPIB interface, usethei bconf i g function
(option | bcHSCabl eLengt h). The value passed to i bconf i g should
specify the number of meters of cablein your GPIB configuration. If you
specify a cable length that is much smaller than what you actually use,
the transferred data could become corrupted. If you specify a cable length
longer than what you actually use, the datais transferred successfully,
but more slowly than if you specified the correct cable length.

In additionto using i bconf i g to configure your GPIB interface for
H$488, the Controller-In-Charge must send out GPIB command bytes
(interface messages) to configure other devices for HS488 transfers.

NI-488.2 User Manual for Windows 7-2 www.natinst.com



Chapter 7 NI-488.2 Programming Techniques

If you are using device-level calls, the NI-488.2 software automatically
sends the HS488 configuration message to devices. If you enabled the
HS488 protocol in the NI-488.2 Configuration utility, the N1-488.2
software sends out the HS488 configuration message when you usei bdev
to bring adevice online. If you cal i bconf i g to change the GPIB cable
length, the N1-488.2 software sends out the HS488 message again, the next
time you call adevice-level function.

If you are using board-level traditional NI-488.2 calls or multi-device
NI-488.2 calls and you want to configure devicesfor high-speed, you must
send the HS488 configuration messages using i bend or SendCnds. The
H$488 configuration message is made up of two GPIB command bytes.
Thefirst byte, the Configure Enable (CFE) message (hex 1F), places all
H$488 devices into their configuration mode. Non-HS488 devices should
ignore this message. The second byte isa GPIB secondary command that
indicates the number of meters of cable in your system. It is called the
Configure (CFGn) message. Because HS488 can operate only with cable
lengthsof 1to 15 m, only CFGn valuesof 1 through 15 (hex 61 through 6F)
arevalid. If the cable length was configured properly in the NI1-488.2
Configuration utility, you can determine how many meters of cable arein
your system by callingi bask (option | baHSCabl eLengt h) in your
application. For more information about CFE and CFGn messages, refer to
the Multiline Interface Messages topic in the NI1-488.2 online help. For
instructions on accessing the online help, refer to the Using the NI-488.2
Documentation section in About This Manual.

System Configuration Effects on HS488

Maximum HS488 data transfer rates can be limited by your host computer
and GPIB system setup. For example, when using a PC-compatible
computer with PCI bus, the maximum obtainable transfer rate is

8 Mbytes/s, but when using a PC-compatible computer with ISA bus, the
maximum transfer rate obtainableis only 2 Mbytes/s. The same |EEE 488
cabling constraints for a 350 ns T1 delay apply to H$488. Asyou increase
the amount of cable in your GPIB configuration, the maximum data
transfer rate using HS488 decreases. For example, two HS488 devices
connected by two meters of cable can transfer data faster than four HS488
devices connected by 4 m of cable.
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Waiting for GPIB Conditions

You can usethei bwai t function to obtain the current i bst a value or to
suspend your application until aspecified condition occurs on the GPIB. If
you usei bwai t with aparameter of zero, it immediately updatesi bst a
and returns. If you want to usei bwai t to wait for one or more events to
occur, pass await mask to the function. The wait mask should always
include the TIMO event; otherwise, your application is suspended
indefinitely until one of the wait mask events occurs.

Asynchronous Event Notification in Win32
NI-488.2 Applications

Win32 NI-488.2 applications can asynchronously receive event
notificationsusing thei bnot i f y function. This function is useful if you
want your application to be notified asynchronously about the occurrence
of one or more GPIB events. For example, you might choose to use

i bnot i fy if your application only needsto interact with your GPIB device
when it isrequesting service. After callingi bnot i fy, your application
does not need to check the status of your GPIB device. Then, when your
GPIB device requests service, the NI-488.2 driver automatically notifies
your application that the event has occurred by invoking a callback
function. The callback function isregistered with the NI1-488.2 driver when
thei bnoti fy call ismade.

Calling the ibnotify Function
i bnot i fy hasthe following function prototype:

i bnotify (
int ud,// unit descriptor
int mask,// bit mask of GPIB events
Gpi bNot i fyCal | back_t Cal | back,
/1 callback function
void * RefData// user-defined reference data

)

Both board-level and device-level i bnot i f y calls are supported by the
NI-488.2 driver. If you are using device-level calls, you cal i bnoti fy
with adevice handle for ud and amask of RQS, CMPL, END, or TIMO. If
you are using board-level calls, youcall i bnot i f y withaboard handlefor
ud and amask of any valuesexcept RQSor ERR. Thei bnot i f y mask bits
areidentical tothei bwai t mask bits. In the example of waiting for your
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GPIB device to request service, you might choose to passi bnoti fy a
mask with RQS (for device-level) or SRQI (for board-level).

The callback function that you register with thei bnot i f y call isinvoked
by the NI-488.2 driver when one or more of the mask bits passed to
i bnoti fy is TRUE. The function prototype of the callback is as follows:

int _ stdcall Callback (
int ud,// unit descriptor
int ibsta,// ibsta val ue
int iberr,// iberr value
long ibentl,// ibcntl val ue
void * RefData// user-defined reference data

)

The callback function is passed a unit descriptor, the current values of the
NI-488.2 global variables, and the user-defined reference data that was
passed to the original i bnot i fy call. The NI-488.2 driver interprets the
return value for the callback as a mask value that is used to automatically
rearm the callback if it is non-zero. For a compl ete description of

i bnot i fy, refer to the NI-488.2 online help. For instructions on accessing
the online help, refer to the Using the NI-488.2 Documentation section in
About This Manual.

@ Note Thei bnoti fy callback isexecuted in aseparate thread of execution from the rest
of your application. If your application will be performing other NI-488.2 operationswhile
itisusingi bnot i fy, use the per-thread NI-488.2 global s that are provided by the
Thr eadl bst a, Thr eadl berr, Thr eadl bcnt , and Thr eadl bent | functions described
in the Writing Multithreaded Win32 NI-488.2 Applications section of this chapter. In
addition, if your application needs to share global variables with the callback, use a
synchronization primitive (for example, asemaphore) to protect accessto any globals. For
more information about the use of synchronization primitives, refer to the documentation
about using Win32 synchronization objects that came with your development tools.

ibnotify Programming Example

The following code is an example of how you can usei bnot i fy inyour
application. Assume that your GPIB device is a multimeter that you
program it to acquire areading by sending "SEND DATA" . The multimeter
requests service when it has areading ready, and each reading is afloating
point value.

In this example, globals are shared by the Cal | back thread and the main
thread, and the access of the globalsis not protected by synchronization.
In this case, synchronization of access to these globalsis not necessary
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because of the way they are used in the application: only asinglethread is
writing the global values and that thread only adds information (increases
the count or adds another reading to the array of floats).

int _ stdcall McCallback (int ud, int Locallbsta, int Locallberr
Il ong Local Ibcntl, void *RefData);

i nt Readi ngsTaken = 0;

fl oat Readi ngs[1000];

BOOL Devi ceError = FALSE

char expectedResponse = 0x43;

int main()

{

int ud;

/1l Assign a unique identifier to the device and store it in the

/1 variable ud. ibdev opens an avail abl e device and assigns it to
/1l access GPIBO with a primary address of 1, a secondary address of O,
/1l a timeout of 10 seconds, the END nessage enabl ed, and t he ECS node
/1 disabled. If ud is less than zero, then print an error nessage
/1l that the call failed and exit the program

ud = i bdev (0,// connect board
1, /1l primary address of GPIB device
0, /'l secondary address of GPIB device
T10s, /1 10 second |/O tinmeout
1, /1 EOT node turned on
0); /1 ECS node di sabl ed

if (ud <0) {
printf ("ibdev failed.\n");
return O;

}

/'l lssue a request to the device to send the data. If the ERR bit
/Il is set inibsta, then print an error nmessage that the call failed
/1l and exit the program
ibwt (ud, "SEND DATA", 9L);
if (ibsta & ERR) {

printf ("unable to wite to device.\n");

return O;

}

/1l set up the asynchronous event notification on RQS
i bnotify (ud, RQS, MCallback, NULL);
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if (ibsta & ERR) {
printf ("ibnotify call failed.\n");
return O;

}

whil e ((Readi ngsTaken < 1000) && ! (DeviceError)) {
/1l Your application does useful work here. For exanple, it
/'l m ght process the device readings or do any ot her useful work

}

/] disable notification
ibnotify (ud, 0, NULL, NULL);

/1l Call the ibonl function to disable the hardware and software.
i bonl (ud, 0);
return 1;

int __stdcall MCallback (int Localud, int Locallbsta, int Locallberr
| ong Local I bcntl, void *RefData)

char Spol | Byte;
char ReadBuffer[40];

/1 1f the ERR bit is set in Locallbsta, then print an error
/1 message and return
if (Locallbsta & ERR) {
printf ("GPIB error %d has occurred. No nore call backs.\n"
Local | berr);
Devi ceError = TRUE
return O;
}
/'l Read the serial poll byte fromthe device. If the ERR bit is set
/1l in ibsta, then print an error nmessage and return
Local I bsta = ibrsp (Local Ud, &Spol I Byte);
if (Locallbsta & ERR) {
printf ("ibrsp failed. No more call backs.\n");
Devi ceError = TRUE
return O;

}

/1 1f the returned status byte equals the expected response, then
/1 the device has valid data to send; otherwise it has a fault
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/1l condition to report.
if (SpollByte != expectedResponse) {
printf("Device returned invalid response. Status byte = Ox%\n",
Spol | Byte);
Devi ceError = TRUE;
return O;

}

/!l Read the data fromthe device. If the ERR bit is set in ibsta,
// then print an error nessage and return.
Local I bsta = ibrd (Local Ud, ReadBuffer, 40L);
if (Locallbsta & ERR) {
printf ("ibrd failed. No nore call backs.\n");
Devi ceError = TRUE;
return O;

}

/1l The string returned by ibrd is a binary string whose length is
/1 specified by the byte count in ibcntl. However, many GPI B

/1l instruments return ASClI| data strings and this exanple nmakes this
/1l assunption. Because of this, it is possible to add a NULL

/1l character to the end of the data received and use the printf()

/1l function to display the ASCI|I data. The follow ng code

/1 illustrates that.

ReadBuffer[ibcntl] = “\0’;

/1l Convert the data into a nuneric val ue.
sscanf (ReadBuffer, "% ", &Readi ngs[Readi ngsTaken]);

/1 Display the data.
printf(“Reading : %\n", Readings[Readi ngsTaken]);

Readi ngsTaken += 1;
i f (Readi ngsTaken >= 1000) {
return O;

}

el se {
/1l lssue a request to the device to send the data and rearm
/1 callback on RQS.
Local Ibsta = ibwt (Local Ud, "SEND DATA", 9L);
if (Locallbsta & ERR) {
printf ("ibwt failed. No more call backs.\n");
Devi ceError = TRUE;
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return O;
}
el se {

return RQS;
}

Writing Multithreaded Win32 NI-488.2 Applications

If you are writing a multithreaded NI-488.2 application and you plan to
make all of your NI-488.2 calls from a single thread, you can safely
continue to use the traditional NI-488.2 global variables (i bst a, i berr,
i bent, i bent ). The NI-488.2 global variables are defined on a
per-process basis, so each process accesses its own copy of the NI1-488.2
globals.

If you are writing a multithreaded NI-488.2 application and you plan to
make NI-488.2 calls from more than a single thread, you cannot safely
continueto usethetraditional NI1-488.2 global variableswithout someform
of synchronization (for example, asemaphore). To understand why, refer to
the following example.

Assume that a process has two separate threads that make NI-488.2 calls,
thread #1 and thread #2. Just as thread #1 is about to examine one of the
NI-488.2 globals, it gets preempted and thread #2 is allowed to run.
Thread #2 proceeds to make several NI1-488.2 calls that automatically
update the NI-488.2 globals. Later, when thread #1 is allowed to run, the
NI-488.2 global that it is ready to examine is no longer in aknown state
and itsvalue is no longer reliable.

The previous example illustrates a well-known multithreading problem.
It is unsafe to access process-global variables from multiple threads of
execution. You can avoid this problem in two ways:

»  Use synchronization to protect access to process-global variables.
* Do not use process-global variables.

If you choose to implement the synchronization solution, you must ensure
that the code making NI-488.2 calls and examining the NI-488.2 globals

modified by aNI-488.2 call is protected by asynchronization primitive. For
example, each thread might acquire asemaphore before making aNI-488.2
call and then release the semaphore after examining the N1-488.2 globals
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modified by the call. For moreinformation about the use of synchronization
primitives, refer to the documentation about using Win32 synchronization
objects that came with your development tools.

If you choose not to use process-global variables, you can access per-thread
copiesof theNI-488.2 global variablesusing aspecial set of N1-488.2 calls.
Whenever athread makes a NI-488.2 call, the driver keeps a private copy
of the NI-488.2 globals for that thread. The driver keeps a separate private
copy for each thread. Thefollowing code showsthe set of functionsyou can
use to access these per-thread NI1-488.2 global variables:

int Threadl bsta(); /1 return thread-specific ibsta
int Threadl berr(); /1 return thread-specific iberr
int Threadl bent () ; /1 return thread-specific ibcnt

long Threadlbcntl (); // return thread-specific ibcntl

In your application, instead of accessing the per-process NI-488.2 globals,
substitute acall to get the corresponding per-thread NI-488.2 global. For
example, the following line of code,

if (ibsta & ERR)

could be replaced by,
if (Threadl bsta() & ERR)

A quick way to convert your application to use per-thread NI-488.2 globals
isto add the following #def i ne lines at the top of your C file:

#define ibsta Threadl bsta()
#define iberr Threadl berr()
#define ibcnt Threadl bent ()
#define ibcntl Threadl bentl ()

@ Note If youareusingi bnoti fy inyour application (see the Asynchronous Event
Notification in Win32 NI-488.2 Applications section of this chapter), thei bnoti fy
callback is executed in a separate thread that is created by the NI-488.2 driver. Therefore,
if your application makes NI1-488.2 callsfrom thei bnot i f y callback function and makes
NI-488.2 calls from other places, you must use the Thr eadl bst a, Thr eadl berr,
Threadl bent, and Thr eadl bent | functions described in this section, instead of the
per-process NI-488.2 globals.
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Device-Level Calls and Bus Management

The device-level traditional NI-488.2 calls are designed to perform all of
the GPIB management for your application. However, the N1-488.2 driver
can handle bus management only when the GPIB interfaceis CIC
(Controller-In-Charge). Only the CIC isableto send command bytesto the
devices on the busto perform device addressing or other bus management
activities.

Use one of the following methods to make your GPIB interface the CIC:

« Ifyour GPIB interfaceisconfigured asthe System Controller (default),
it automatically makesitself the CIC by asserting the IFC line thefirst
time you make a device-level call.

»  |If your setup includes more than one Controller, or if your GPIB
interface is not configured as the System Controller, use the CIC
Protocol method. To use the protocol, issue thei bconf i g function
(option I bcCl CPROT) or use the NI-488.2 Configuration utility to
activate the CIC protocol. If theinterfaceis not CIC, and you make a
device-level call with the CIC protocol enabled, the following
sequence occurs:

The GPIB interface asserts the SRQ line.
The current CIC serial pollstheinterface.

NP

3. Theinterface returns aresponse byte of hex 42.
4. The current CIC passes control to the GPIB interface.

If the current CIC does not pass control, the NI-488.2 driver returns the
ECIC error codeto your application. Thiserror can occur if the current CIC
does not understand the CIC protocol. If this happens, you could send a
device-specific command requesting control for the GPIB interface. Then,
use aboard-level i bwai t command to wait for CIC.

Talker/Listener Applications

Although designed for Controller-In-Charge applications, you can also use
the NI-488.2 software in most non-Controller situations. These situations
are known as Talker/Listener applications because the interface is not the
GPIB Controller.

A Taker/Listener application typically usesi bwai t with amask of 0 to
monitor the status of the interface. Then, based on the status bits set in
i bst a, the application takes whatever action is appropriate. For example,

© MNational Instruments Corporation 7-11 NI-488.2 User Manual for Windows



Chapter 7 NI-488.2 Programming Techniques

Serial Polling

the application could monitor the status bits TACS (Talker Active State)
and LACS (Listener Active State) to determine when to send data to or
receive data from the Controller. The application could also monitor the
DCAS (Device Clear Active State) and DTAS (Device Trigger Active
State) bits to determine if the Controller has sent the device clear (DCL or
SDC) or trigger (GET) messagesto the interface. If the application detects
adevice clear from the Controller, it might reset the internal state of
message buffers. If it detects atrigger message from the Controller, the
application might begin an operation, such astaking avoltagereadingif the
application is actually acting as a voltmeter.

Y ou can use seria polling to obtain specific information from GPIB
deviceswhen they request service. When the GPIB SRQ lineis asserted, it
signalsthe Controller that aservicerequest ispending. The Controller must
then determine which device asserted the SRQ line and respond
accordingly. The most common method for SRQ detection and servicingis
the serial poll. This section describes how to set up your application to
detect and respond to service requests from GPIB devices.

Service Requests from IEEE 488 Devices

|EEE 488 devices request service from the GPIB Controller by asserting
the GPIB SRQ line. When the Controller acknowledges the SRQ, it serial
polls each open device on the bus to determine which device requested
service. Any device requesting service returns a status byte with bit 6 set
and then unasserts the SRQ line. Devices not requesting service return a
statusbytewith bit 6 cleared. Manufacturers of | EEE 488 devices uselower
order bits to communicate the reason for the service request or to
summarize the state of the device.

Service Requests from IEEE 488.2 Devices

The IEEE 488.2 standard refined the bit assignments in the status byte. In
addition to setting bit 6 when requesting service, |EEE 488.2 devices also
use two other bitsto specify their status. Bit 4, the Message Available bit
(MAV), is set when the device is ready to send previously queried data.
Bit 5, the Event Status bit (ESB), is set if one or more of the enabled
|EEE 488.2 events occurs. These events include power-on, user request,
command error, execution error, device dependent error, query error,
request control, and operation complete. The device can assert SRQ when
ESB or MAYV are set, or when a manufacturer-defined condition occurs.
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Automatic Serial Polling

Y ou can enable automatic serial polling if you want your application to
conduct a serial poll automatically when the SRQ lineis asserted. The
autopolling procedure occurs as follows:

1. Toenableautopolling, usethe configuration function, i bconf i g, with
option | bcAUTOPQOLL, or the NI1-488.2 Configuration utility.
(Autopolling is enabled by default.)

2. Whenthe SRQ lineisasserted, the driver automatically serial pollsthe
open devices.

3. Each positive seria poll response (bit 6 or hex 40 is set) isstored in a
gueue associated with the device that sent it. The RQS hit of the device
statusword, i bst a, is set.

4. The polling continues until SRQ is unasserted or an error conditionis
detected.

5. To empty the queue, use thei br sp function. i br sp returnsthe first
queued response. Other responses are read in first-in-first-out (FIFO)
fashion. If the RQS hit of the statusword isnot set wheni brsp is
called, aseria poll is conducted and returns the response received.
Empty the queue as soon as an automatic serial poll occurs, because
responses might be discarded if the queueisfull.

6. If the RQShbit of the statusword is still set after i br sp iscalled, the
response byte queue contains at |east one more response byte. If this
happens, continue to call i br sp until RQSiscleared.

Stuck SRQ State

If autopolling is enabled and the GPIB interface detects an SRQ, the driver
seria polls all open devices connected to that interface. The serial poll
continues until either SRQ unasserts or all the devices have been polled.

If no device responds positively to the seria poll, or if SRQ remainsin
effect because of afaulty instrument or cable, astuck SRQ stateisin effect.
If this happens during ani bwai t for RQS, the driver reports the ESRQ
error. If the stuck SRQ state happens, no further pollsare attempted until an
i bwai t for RQSismade. Wheni bwai t isissued, the stuck SRQ stateis
terminated and the driver attempts a new set of serial polls.
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Autopolling and Interrupts

If autopolling and interrupts are both enabled, the NI1-488.2 software can
perform autopolling after any device-level NI-488.2 call provided that no
GPIB I/Qiscurrently in progress. In this case, an automatic serial poll can
occur even when your application is not making any callsto the NI1-488.2
software. Autopolling can also occur when adevice-level i bwai t for RQS
isin progress. Autopolling is not allowed when an application calls a
board-level traditional or multi-device NI-488.2 call, or the stuck SRQ
(ESRQ) condition occurs.

Windows 98/95

In Windows 98/95, you can use your GPI B interface without interrupts, but
the NI-488.2 software performance is significantly slower without
interrupts. For example, transfer sizes between 1 and 10 bytes transfer at a
rate of only 2% of the transfer rate with enabled interrupts. Asthe transfer
size increases, the performance degradation decreases slightly, but it
remains a significant problem for all transfers under 1 Mbyte. For
instructions on how to assign aninterrupt to your GPIB interfaceif onewas
not assigned, refer to the Enabling Interrupts section in Appendix D,
Windows 98/95: Troubleshooting and Common Questions.

Windows 2000/NT

The NI-488.2 software for Windows 2000/NT does not function properly
if interrupts are disabled.

SRQ and Serial Polling with Device-Level Traditional NI-488.2 Calls

Y ou can use the device-level traditional NI-488.2 call i br sp to conduct a
serial poll. i br sp conducts asingle serial poll and returns the seria poll
response byte to the application. If automatic seria polling is enabled, the
application can usei bwai t to suspend program execution until RQS
appearsin the status word, i bst a. The program can then call i br sp to
obtain the serial poll response byte.

The following example shows you how to usethei bwai t andi brsp
functionsinatypical SRQ servicing situation when automatic serial polling
is enabled:

#i ncl ude "decl -32. h"
char Get Seri al Pol | Response ( int DeviceHandl e )

{
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char Serial Pol | Response = 0;

i bwait ( DeviceHandle, TIMO| RQS );

if (ibsta & RQS) {

printf ( "Device asserted SRQ\n" );

/* Use ibrsp to retrieve the serial poll response. */
i brsp ( DeviceHandl e, &Seri al Pol | Response );

}

return Serial Pol | Response;

}
SRQ and Serial Polling with Multi-Device NI-488.2 Calls

The NI-488.2 software includes a set of multi-device NI-488.2 calls that
you can use to conduct SRQ servicing and serial polling. Calls pertinent to
SRQ servicing and seria polling are Al | Spol | , ReadSt at usByt e,

Fi ndRQS, Test SRQ and Wai t SRQ Following are descriptions of each of
the calls:

e Al Spol | canserial poll multiple deviceswith asinglecall. It places
the status bytes from each polled instrument into a predefined array.
Then, you must check the RQS hit of each status byte to determine
whether that device requested service.

* ReadStat usByt e issimilar to Al | Spol |, except that it only serial
pollsasingle device. It isaso similar to the device-level NI-488.2
i br sp function.

e Fi ndRQS serid pollsalist of devices until it finds adevicethat is
requesting service or until it has polled al of the devices on thelist.
Thecall returnstheindex and status byte val ue of the device requesting
service.

* Test SRQdetermines whether the SRQ lineis asserted and returns to
the program immediately.

* Wit SRQissimilar to Test SRQ except that Wi t SRQ suspends the
application until either SRQ is asserted or the timeout period is
exceeded.

The following examples use these calls to detect SRQ and then determine
which device requested service. In these examples, three devices are
present on the GPIB at addresses 3, 4, and 5, and the GPIB interfaceis
designated as bus index 0. The first example uses Fi ndRQS to determine
which deviceisrequesting service, and the second exampleusesAl | Spol |
to seria poll all three devices. Both examples use Wai t SRQto wait for the
GPIB SRQ line to be asserted.
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Example 1: Using FindRQS
This example shows you how to use Fi ndRQS to find the first device that
is requesting service:

voi d Get ASeri al Pol | Response ( char *Devi cePad,
char *Devi ceResponse )

{
char Seri al Pol | Response = 0;
int WiitResult;
Addr4882_t Addrlist[4] = {3, 4,5, NOADDR};
Wai t SRQ (0, &WaitResult);
if (WitResult) {
printf ("SRQis asserted.\n");
Fi ndR@S ( O, AddrlList, &Serial Poll Response );
if (!(ibsta & ERR)) {
printf ("Device at pad % returned byte
%.\n", AddrList[ibcnt], (int)
Seri al Pol | Response) ;
*Devi cePad = AddrList[ibcnt];
*Devi ceResponse = Seri al Pol | Response;
}
}
return;
}

Example 2: Using AliSpoll

This example shows you how to use Al | Spol | to seria poll three devices
with asingle call:

void Get Al | Seri al Pol | Responses ( Addr4882_t AddrList[],
short Responselist[] )
{
int WiitResult;
Wai t SRQ (0, &WaitResult);
if ( WaitResult ) {
printf ( "SRQis asserted.\n" );
Al Spoll ( 0, AddrlList, Responselist );
if (!(ibsta & ERR)) {
for (i = 0; AddrList[i] != NOADDR i++) {
printf ("Device at pad % returned byte
%.\n", AddrList[i], ResponseList[i] );
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return;

}

Parallel Polling

Although parallel polling is not widely used, it is auseful method for
obtaining the status of more than one device at the same time. The
advantage of parallel polling isthat asingle parallel poll can easily check
up to eight individual devicesat once. In comparison, eight separate serial
pollswould be required to check eight devicesfor their seria poll response
bytes. The value of the individual status bit (i st ) determines the parallel
poll response.

Implementing a Parallel Poll

Y ou can implement parallel polling with either the traditional or
multi-device N1-488.2 calls. If you use multi-device NI-488.2 calls to
execute parallel polls, you do not need extensive knowledge of the parallel
polling messages. However, you should use the traditional NI-488.2 calls
for parallel polling when the GPIB interface is not the Controller, and the
interface must configure itself for aparallel poll and set its own individual
status bit (i st ).

Parallel Polling with Traditional NI-488.2 Calls

Complete the following steps to implement parallel polling using
traditional NI-488.2 calls. Each step contains example code.

1. Configurethe devicefor parallel polling using thei bppc function,
unless the device can configureitself for parallel polling.

i bppc requires an 8-bit value to designate the data line number, the
i st sense, and whether the function configures the device for the
parallel poll. The bit pattern is asfollows:

011ESD2D1 DO

Eis1todisableparalel polling and Oto enable parallel polling for that
particular device.

Sislif thedeviceisto assert the assigned datalinewheni st is1, and
0 if the device isto assert the assigned datalinewheni st isO.

D2 through DO determine the number of the assigned dataline. The
physical line number isthe binary line number plus one. For example,
DIO3 has a binary bit pattern of 010.
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The following example code configures a device for parallel polling
using traditional NI-488.2 calls. The device asserts DIO7 if itsi st
isO.

Inthisexample, thei bdev command opensadevicethat hasaprimary
address of 3, has no secondary address, has atimeout of 3 s, asserts
EQI with the last byte of awrite operation, and has EOS characters
disabled.

Thefollowing call configuresthedevicetorespondtothepoll on DIO7
and to assert the linein the case whenitsi st is0. Passthe binary bit
pattern, 0110 0110 or hex 66, to i bppc.

#i ncl ude "decl -32. h"

char ppr;

dev = ibdev(0,3,0,T3s,1,0);
i bppc(dev, 0x66);

If the GPIB interface configuresitself for a paralel poll, you should
till usethei bppc function. Pass the interface index or an interface
unit descriptor value as the first argument ini bppc. Also, if the
individual statushit (i st ) of theinterface needsto be changed, usethe
i bi st function.

In the following example, the GPIB interface isto configure itself to
participatein aparallel poll. It assertsDIO5 wheni st islif aparallel
poll is conducted.

i bppc(0, 0x60C);
i bist(0, 1);

Conduct the parallel poll using i br pp and check the response for a
certain value. The following example code performs the parallel poll
and compares the response to hex 10, which corresponds to DIOS. If
that bit isset, thei st of the deviceis 1.

i brpp(dev, &ppr);
if (ppr & 0x10) printf("ist = 1\n");

Unconfigure the device for parallel polling with i bppc. Notice that
any value having the parallel poll disablebit set (bit 4) inthe bit pattern
disables the configuration, so you can use any value between hex 70
and 7E.

i bppc(dev, 0x70);
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Parallel Polling with Multi-Device NI-488.2 Calls

Complete the following steps to implement parallel polling the using
multi-device NI-488.2 calls. Each step contains example code.

1. Configurethedevicefor parallel polling using the PPol | Confi g call,
unless the device can configure itself for parallel polling. The
following example configuresadevice at address 3to assert dataline 5
(DIO5) wheniitsi st valueis 1.

#i ncl ude "decl -32. h"

char response;

Addr 4882_t AddressList[2];

/* The follow ng conmand clears the GPIB. */

Sendl FC(0) ;

/* The value of sense is compared with the ist bit
of the device and determ nes whether the data
line is asserted. */

PPol | Config(0, 3,5, 1);

2. Conduct the parallel poll using PPol | , store the response, and check
the response for a certain value. In the following example, because
DIO5 is asserted by the deviceif i st is 1, the program checks bit 4
(hex 10) in the response to determine the value of i st .

PPol | (0, &response);

/* If response has bit 4 (hex 10) set, the ist bit
of the device at that tine is equal to 1. If
it does not appear, the ist bit is equal to O.
Check the bit in the follow ng statenent. */

if (response & 0x10) {
printf("The ist equals 1.\n");

}
el se {

printf("The ist equals 0.\n");
}

3. Unconfigurethedevicefor paralel polling using PPol | Unconfi g, as
shown in thefollowing example. In this exampl e, the NOADDR constant
must appear at the end of the array to signal the end of the addresslist.
If NOADDRistheonly valueinthe array, all devicesreceivethe parallel
poll disable message.

AddressList[0] = 3;
Addr essLi st[1] = NOADDR,
PPol | Unconfi g(0, AddressList);
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GPIB Basics

The ANSI/IEEE Standard 488.1-1987, also known as General Purpose
Interface Bus (GPIB), describes a standard interface for communication
between instruments and controllers from various vendors. It contains
information about electrical, mechanical, and functional specifications.
GPIB isadigital, 8-bit parallel communicationsinterface with datatransfer
rates of 1 Mbyte/s and higher, using a three-wire handshake. The bus
supportsone System Controller, usually acomputer, and up to 14 additional
instruments. The ANSI/IEEE Standard 488.2-1992 extends | EEE 488.1 by
defining a bus communication protocol, acommon set of data codes and
formats, and a generic set of common device commands.

Talkers, Listeners, and Controllers

GPIB devices can be Talkers, Listeners, or Controllers. A Talker sends out
data messages. Listeners receive data messages. The Controller, usualy a
computer, manages the flow of information on the bus. It defines the
communication links and sends GPIB commands to devices.

Some devices are capable of playing more than onerole. A digital
voltmeter, for example, can be a Talker and aListener. If your system hasa
National Instruments GPIB interface and softwareinstalled, it can function
as a Talker, Listener, and Controller.

Controller-In-Charge and System Controller

You can have multiple Controllers on the GPIB, but only one Controller at
atime can bethe active Controller, or Controller-In-Charge (CIC). TheCIC
can be either active or inactive (standby). Control can pass from the current
CIC to an idle Controller, but only the System Controller, usualy a GPIB
interface, can make itself the CIC.
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Appendix A GPIB Basics

GPIB Addressing

All GPIB devices and interfaces must be assigned a unique GPIB address.
A GPIB addressismade up of two parts: aprimary address and an optional
secondary address.

The primary address is anumber in the range 0 to 30. The Controller uses
thisaddressto form atalk or listen addressthat is sent over the GPIB when
communicating with adevice.

A talk addressisformed by setting bit 6, the TA (Talk Active) bit of the
GPIB address. A listen addressis formed by setting bit 5, the LA (Listen
Active) bit of the GPIB address. For example, if adeviceisat address 1,
the Controller sends hex 41 (address 1 with bit 6 set) to make the device a
Talker. Because the Controller isusually at primary address 0, it sends
hex 20 (address O with bit 5 set) to makeitself aListener. Figure A-1 shows
the configuration of the GPIB address hits.

Bit Position 7 6 5 4 3 2 1 0

Meaning 0 TA | LA GPIB Primary Address
(range 0-30)

Figure A-1. GPIB Address Bits

With some devices, you can use secondary addressing. A secondary
addressisanumber in the range hex 60 to hex 7E. When you use secondary
addressing, the Controller sends the primary talk or listen address of the
device followed by the secondary address of the device.

Sending Messages across the GPIB

Devices on the bus communicate by sending messages. Signals and lines
transfer these messages across the GPI B interface, which consists of

16 signal lines and 8 ground return (shield drain) lines. The 16 signal lines
are discussed in the following sections.

Data Lines

Eight data lines, DIO1 through DIO8, carry both data and command
messages.
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Handshake Lines

Appendix A GPIB Basics

Three hardware handshake lines asynchronously control the transfer of
message bytes between devices. This processis a three-wire interlocked
handshake, and it guarantees that devices send and receive message bytes
on the data lines without transmission error. Table A-1 summarizes the
GPIB handshake lines.

Table A-1. GPIB Handshake Lines

Line Description
NRFD Listening deviceis ready/not ready to receive a
(not ready for data) | message byte. Also used by the Talker to signal

high-speed GPIB transfers.

NDAC Listening device has/has not accepted a message
(not data accepted) | byte.
DAV Talking device indicates signals on data lines are
(data valid) stable (valid) data.

Interface Management Lines

Five hardware lines manage the flow of information across the bus.
Table A-2 summarizes the GPIB interface management lines.

Table A-2. GPIB Interface Management Lines

(end or identify)

Line Description
ATN Controller drives ATN true when it sends
(attention) commands and false when it sends data messages.
IFC System Controller drives the IFC line to initialize
(interface clear) | the busand makeitself CIC.
REN System Controller drives the REN lineto place
(remote enable) devicesin remote or local program mode.
SRQ Any device can drive the SRQ lineto
(servicerequest) | asynchronously request service from the Controller.
EQI Talker usesthe EOI line to mark the end of a data

message. Controller uses the EOI line when it
conducts aparallel poll.
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Status Word Conditions

Thisappendix gives adetailed description of the conditions reported in the
statusword, i bst a.

For information about how to usei bst a inyour application program, refer
to the N1-488.2 online help. For instructions on accessing the online help,
refer to the Using the NI-488.2 Documentation section in About This
Manual.

Eachbitini bst a can beset for devicecalls(dev), board calls (brd), or both
(dev, brd). Table B-1 shows the status word layout.

Table B-1. Status Word Layout

Mnemonic Bit Position | Hex Value Type Description
ERR 15 8000 dev, brd NI-488.2 error
TIMO 14 4000 dev, brd Time limit exceeded
END 13 2000 dev, brd END or EOS detected
SRQI 12 1000 brd SRQ interrupt received
RQS 11 800 dev Device requesting service
CMPL 8 100 dev, brd 1/0O completed
LOK 7 80 brd Lockout State
REM 6 40 brd Remote State
CIC 5 20 brd Controller-In-Charge
ATN 4 10 brd Attention is asserted
TACS 3 8 brd Talker
LACS 2 4 brd Listener
DTAS 1 2 brd Device Trigger State
DCAS 0 1 brd Device Clear State
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Appendix B Status Word Conditions

ERR (dev, brd)

ERR isset in the status word following any call that resultsin an error. You
can determine the particular error by examining the error variablei berr.
Appendix C, Error Codes and Solutions, describes error codes that are
recordedini ber r aong with possible solutions. ERR iscleared following
any call that does not result in an error.

TIMO (dev, brd)

TIMO indicates that the timeout period has expired. TIMO is set in the
statusword foll owing any synchronous /O functions (for example, i bend,
i brd,ibwt,Recei ve, Send, and SendCnds) if the timeout period
expires before the 1/0O operation has completed. TIMO isalso set in the
status word following ani bwai t ori bnoti fy cal if the TIMO bitis set
in the mask parameter and the timeout period expires before any other
specified mask bit condition occurs. TIMO is cleared in al other
circumstances.

END (dev, brd)

END indicates either that the GPIB EOI line has been asserted or that the
EOS byte has been received, if the software is configured to terminate a
read on an EOS byte. If the GPIB interface is performing a shadow
handshake as aresult of thei bgt s function, any other function can return
a status word with the END bit set if the END condition occurs before or
during that call. END is cleared when any 1/O operation isinitiated.

Some applications might need to know the exact I/O read termination mode
of aread operation—EOI by itself, the EOS character by itself, or EOI
plus the EOS character. You can usethei bconf i g function (option

I bcEndBi t | sNor mal ) to enable amodein which the END bit is set only
when EQI isasserted. In thismode, if the 1/O operation compl etes because
of the EOS character by itself, END isnot set. The application should check
the last byte of the received buffer to seeiif it isthe EOS character.
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SRQI (brd)
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RQS (dev)

SRQI indicates that a GPIB deviceis requesting service. SRQI is set
whenever the GPIB interfaceis CIC, the GPIB SRQ lineisasserted, and the
automatic serial poll capability isdisabled. SRQI iscleared either when the
GPIB interface ceases to be the CIC or when the GPIB SRQ lineis
unasserted.

RQS appears in the status word only after adevice-level call and indicates
that the device is requesting service. RQS is set whenever one or more
positive serial poll response bytes have been received from the device. A
positive seria poll response byte alwayshasbit 6 asserted. Automatic serial
polling must be enabled (it is enabled by default) for RQS to automatically
appear ini bst a. You can also wait for adevice to request service
regardless of the state of automatic serial polling by callingi bwai t witha
mask that contains RQS. Do not issueani bwai t call on RQSfor adevice
that does not respond to serial polls. Usei br sp to acquire the seria poll
response bytethat wasreceived. RQSiscleared when all of the stored serial
poll response bytes have been reported to you through thei br sp function.

CMPL (dev, brd)

LOK (brd)

CMPL indicates the condition of 1/O operations. It is set whenever an I/O
operation is complete. CMPL is cleared while the I/O operationisin
progress.

L OK indicateswhether theinterfaceisin alockout state. While LOK isset,
the Enabl eLocal ori bl oc call isinoperative for that interface. LOK is
set whenever the GPIB interface detects that the Local Lockout (LLO)
message has been sent either by the GPIB interface or by another
Controller. LOK is cleared when the System Controller unasserts the
Remote Enable (REN) GPIB line.
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REM (brd)

CIC (brd)

REM indicates whether the interface isin the remote state. REM is set
whenever the Remote Enable (REN) GPIB line is asserted and the GPIB
interface detects that its listen address has been sent either by the GPIB
interface or by another Controller. REM is cleared in the following
situations:

*  When REN becomes unasserted.

*  When the GPIB interface as a Listener detects that the Go to Local
(GTL) command has been sent either by the GPIB interface or by
another Controller.

*  Whenthei bl oc functioniscalled whilethe LOK bit iscleared in the
status word.

ATN (brd)

CIC indicates whether the GPIB interfaceisthe Controller-In-Charge. CIC
is set when the Sendl FCor i bsi c cal is executed either while the GPIB
interfaceis System Controller or when another Controller passes control to
the GPIB interface. CIC is cleared either when the GPIB interface detects
Interface Clear (IFC) from the System Controller or when the GPIB
interface passes control to another device.

TACS (brd)

ATN indicates the state of the GPIB Attention (ATN) line. ATN is set
whenever the GPIB ATN lineis asserted, and it is cleared when the ATN
line is unasserted.

TACS indicates whether the GPIB interface is addressed asa Talker. TACS
is set whenever the GPIB interface detects that its talk address (and
secondary address, if enabled) has been sent either by the GPIB interface
itself or by another Controller. TACS is cleared whenever the GPIB
interface detectsthe Untalk (UNT) command, its own listen address, atalk
address other than its own talk address, or Interface Clear (IFC).
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LACS (brd)
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DTAS (brd)

LACS indicates whether the GPIB interface is addressed as a Listener.
LACS s set whenever the GPIB interface detects that its listen address
(and secondary address, if enabled) has been sent either by the GPIB
interface itself or by another Controller. LACS is aso set whenever the
GPIB interface shadow handshakes as aresult of thei bgt s function.
LACS iscleared whenever the GPIB interface detects the Unlisten (UNL)
command, its own talk address, Interface Clear (IFC), or that thei bgt s
function has been called without shadow handshake.

DCAS (brd)

DTAS indicates whether the GPIB interface has detected a device trigger
command. DTAS s set whenever the GPIB interface, asaListener, detects
that the Group Execute Trigger (GET) command has been sent by another
Controller. DTASiscleared on any call immediately following ani bwai t
cal, if the DTAShitissetinthei bwai t mask parameter.

DCAS indicates whether the GPIB interface has detected a device clear
command. DCAS is set whenever the GPIB interface detects that the
Device Clear (DCL) command has been sent by another Controller, or
whenever the GPIB interface as a Listener detects that the Selected Device
Clear (SDC) command has been sent by another Controller.

If youusethei bwait ori bnotify functionto wait for DCAS and the
wait is completed, DCAS s cleared fromi bst a after the next NI-488.2
call. Thesameistrue of readsand writes. If you call aread or write function
such asi bwt or Send, and DCASissetini bst a, thel/O operationis
aborted. DCAS iscleared fromi bst a after the next NI1-488.2 call.
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Error Codes and Solutions

This appendix lists a description of each error, some conditions under
which it might occur, and possible solutions.

Table C-1 lists the GPIB error codes.

Table C-1. GPIB Error Codes

Error iberr
Mnemonic | Value M eaning

EDVR 0 System error

ECIC 1 Function requires GPIB interface to be CIC
ENOL 2 No Listeners on the GPIB

EADR 3 GPIB interface not addressed correctly
EARG 4 Invalid argument to function call

ESAC 5 GPIB interface not System Controller as

required

EABO 6 1/O operation aborted (timeout)

ENEB 7 Nonexistent GPIB interface
EDMA 8 DMA error

EQIP 10 Asynchronous /O in progress

ECAP 11 No capability for operation

EFSO 12 File system error

EBUS 14 GPIB bus error

ESTB 15 Seria poll status byte queue overflow
ESRQ 16 SRQ stuck in ON position

ETAB 20 Table problem
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Appendix C Error Codes and Solutions

EDVR (0)

EDVR isreturned when the interface or device name passed to i bf i nd,
or theinterface index passed to i bdev, cannot be accessed. The global
variablei bent | contains an error code. This error occurs when you try to
access an interface or device that is not installed or configured properly.

EDVR isalso returned if an invalid unit descriptor is passed to any
traditional NI-488.2 call.

Solutions

Possible solutions for this error are as follows:

L]

ECIC (1)

Usei bdev to open adevice without specifying its symbolic name.

Useonly device or interface names that are configured in the N1-488.2
Configuration utility as parametersto thei bf i nd function.

Usethe NI-488.2 Troubleshooting Wizard to ensurethat each interface
you want to access is working properly, as follows:

1. Sdect Start»Programs»National I nstruments
NI-488.2»Explore GPIB.

2. Select Help»Troubleshooting»NI-488.2 Troubleshooting
Wizard.

The Troubleshooting Wizard tests your GPIB interface and
displays the results.

Use the unit descriptor returned from i bdev or i bf i nd asthefirst
parameter in subsequent traditional NI1-488.2 calls. Examine the
variable before the failing function to make sure its value has not been
corrupted.

For more troubleshooting information, refer to the Troubleshooting
EDVR Error Conditions section in Appendix D, Windows 98/95:
Troubleshooting and Common Questions.

ECIC isreturned when one of the following board functionsis called while
theinterfaceis not CIC:

L]

NI-488.2 User Manual for Windows

Any device-level traditional NI1-488.2 callsthat affect the GPIB.

Any board-level traditional NI-488.2 calls that issue GPIB command
bytes: i bcnd, i benda, i bl n, andi br pp.
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Appendix C Error Codes and Solutions

i bcac andi bgt s.

Any NI-488.2 multi-device calls that issue GPIB command bytes:
SendCnds, PPol | , Send, and Recei ve.

Possible solutions for this error are as follows:

ENOL (2)

Usei bsi ¢ or Sendl FC to make the GPIB interface become CIC on
the GPIB.

Usei br sc 1 to make sure your GPIB interface is configured as
System Controller.

In multiple CIC situations, aways be certain that the CIC bit appears
in the statusword i bst a before attempting these calls. If it does not
appear, you can perform ani bwai t (for CIC) call to delay further
processing until control is passed to the interface.

ENOL usually occurs when awrite operation is attempted with no
Listeners addressed. For adevice write, ENOL indicates that the GPIB
address configured for that device in the software does not match the GPIB
address of any device connected to the bus, that the GPIB cable is not
connected to the device, or that the device is not powered on.

ENOL can occur in situations where the GPIB interface is not the CIC and
the Controller asserts ATN before the write call in progress has ended.

Solutions

Possible solutions for this error are as follows:

© MNational Instruments Corporation

Make sure that the GPIB address of your device matches the GPIB
address of the device to which you want to write data.

Use the appropriate hex codeini bcnd to address your device.

Check your cable connections and make sure at |east two-thirds of
your devices are powered on.

Cadl i bpad (ori bsad, if necessary) to match the configured address
to the device switch settings.

c-3 NI-488.2 User Manual for Windows



Appendix C Error Codes and Solutions

EADR (3)

Solutions

EARG (4)

EADR occurs when the GPIB interfaceis CIC and is not properly
addressing itself before read and write functions. This error is usually
associated with board-level functions.

EADR isalso returned by thefunctioni bgt s when the shadow-handshake
feature is requested and the GPIB ATN line is already unasserted. In this
case, the shadow handshake is not possible and the error is returned to
notify you of that fact.

Possible solutions for this error are as follows:

¢ Makesurethat the GPIB interfaceisaddressed correctly before calling
i brd,i bwt, RevRespMsg, or SendDat aByt es.

e Avoidcdlingi bgt s except immediately after ani bend call.
(i bcnd causes ATN to be asserted.)

Solutions

EARG results when an invalid argument is passed to afunction call. The
following are some examples:

e i bt no caled with avalue not in the range O through 17.

e i beos caled with meaningless bits set in the high byte of the second
parameter.

e ibpadoribsad caledwithinvalid addresses.
e i bppc caledwithinvalid parale poll configurations.

e A board-level traditional NI-488.2 call made with avalid device
descriptor, or a device-level traditional NI-488.2 call made with a
board descriptor.

e A multi-device NI-488.2 call made with an invalid address.
e PPol | Confi g called with aninvalid dataline or sense hit.

Possible solutions for this error are as follows:
e Make sure that the parameters passed to the NI-488.2 call are valid.
« Do not use adevice descriptor in aboard function or vice-versa.
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ESAC (9)
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Solutions

EABO (6)

ESAC resultswheni bsi c,i bsr e, Sendl FC, or Enabl eRenot e iscalled
when the GPIB interface does not have System Controller capability.

Give the GPIB interface System Controller capability by callingi brsc 1
or by using the NI-488.2 Configuration utility to configure that capability
into the software.

Solutions

ENEB (7)

EABO indicates that an 1/0O operation has been canceled, usually due

to atimeout condition. Other causes are calling i bst op or receiving the
Device Clear message from the CIC while performing an I/O operation.
Frequently, the 1/0 is not progressing (the Listener is not continuing to
handshake or the Talker has stopped talking), or the byte count in the call
which timed out was more than the other device was expecting.

Possible solutions for this error are as follows:

» Usethe correct byte count ininput functions or have the Talker usethe
END message to signify the end of the transfer.

*  Lengthen the timeout period for the I/O operation using i bt no.

e Make sure that you have configured your device to send data before
you request data.

ENEB occurswhen no GPIB interface exists at the 1/O address specified in
the configuration program. This problem happenswhen the interfaceis not
physically plugged into the system, the I/O address specified during
configuration does not match the actual interface setting, or thereisa
system conflict with the base I/O address.
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Solutions

EDMA (8)

Make sure there is a GPIB interface in your computer that is properly
configured both in hardware and software using avalid base |/O address by
running the NI1-488.2 Troubleshooting Wizard, asfollows:

1. Sdlect Start»Programs»National I1nstruments NI-488.2»Explore
GPIB.

2. Select Help»Troubleshooting»NI-488.2 Troubleshooting Wizard.

The Troubleshooting Wizard tests your GPIB interface and displays
the results.

Solutions

EOQIP (10)

EDMA occursif asystem DMA error is encountered when the NI1-488.2
software attempts to transfer data over the GPIB using DMA.

Possible solutions for this error are as follows:

¢ You can correct the EDMA problem in the hardware by using the
NI-488.2 Configuration utility to reconfigure the hardware to not usea
DMA resource.

e You can correct the EDMA problem in the software by usingi bdna to
disable DMA.

Solutions

EOQIP occurs when an asynchronous 1/0 operation has not finished before
some other call is made. During asynchronous I/O, you can only use

i bstop,ibnotify,ibwait,andibonl or perform other non-GPIB
operations. If any other call is attempted, EOIP is returned.

Resynchronize the driver and the application before making any further
NI-488.2 calls. Resynchronization is accomplished by using one of the
following functions:

i bnotify If thei bst a value passed to thei bnot i f y callback
contains CMPL, the driver and application are
resynchronized.
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i bwai t If thereturned i bst a contains CMPL, the driver and
application are resynchronized.

i bst op The /O is canceled; the driver and application are
resynchronized.
i bonl The /O is canceled and the interface is reset; the driver

and application are resynchronized.

ECAP (11)

ECAP results when your GPIB interface lacks the ability to carry out an
operation or when a particular capability has been disabled in the software
and a call is made that requires the capability.

Solutions

Check the validity of the call, or make sure your GPIB interface and the
driver both have the needed capability.

EFSO (12)

EFSO resultswhen ani br df ori bwtf call encountersaproblem
performing afile operation. Specifically, this error indicates that the
function is unable to open, create, seek, write, or close the file being
accessed. The specific operating system error code for this condition
iscontainedini bent | .

Solutions
Possible solutions for this error are as follows:
»  Make sure the filename, path, and drive that you specified are correct.
* Make sure that the access mode of thefileis correct.
* Make sure there is enough room on the disk to hold thefile.

© MNational Instruments Corporation c-7 NI-488.2 User Manual for Windows



Appendix C Error Codes and Solutions

EBUS (14)

Solutions

ESTB (15)

EBUS results when certain GPIB bus errors occur during device functions.
All device functions send command bytes to perform addressing and other
bus management. Devices are expected to accept these command bytes
within the time limit specified by the default configuration or thei bt no
function. EBUSresultsif atimeout occurred while sending these command
bytes.

Possible solutions for this error are as follows:
e Verify that the instrument is operating correctly.

«  Check for loose or faulty cabling or several powered-off instruments
on the GPIB.

e If thetimeout period istoo short for the driver to send command bytes,
increase the timeout period.

Solutions

ESTB isreported only by thei br sp function. ESTB indicates that one or
more serial poll status bytes received from automatic serial polls have been
discarded because of alack of storage space. Several older status bytes are
available; however, the oldest is being returned by thei br sp call.

Possible solutions for this error are asfollows:
e Cdli brsp morefrequently to empty the queue.

« Disable autopolling with thei bconf i g function (option
I bcAUTOPQOLL) or the NI-488.2 Configuration utility, as follows:

1. Select Start»Programs»National I nstruments
NI-488.2»Explore GPIB to start Measurement & Automation
Explorer.

2. ExpandtheDevicesand | nterfacesdirectory by clicking onthe +
next to the folder.

3. Right-click on your GPIB interface and select Propertiesfrom
the drop-down menu that appears.
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Solutions

ETAB (20)

ESRQ can only be returned by adevice-level i bwai t call with RQS set in
the mask. ESRQ indicates that await for RQS is not possible because the
GPIB SRQ lineis stuck on. This situation can be caused by the following
events:

»  Usually, adevice unknown to the software is asserting SRQ. Because
the software does not know of this device, it can never serial poll the
device and unassert SRQ.

e A GPIB bustester or similar equipment might be forcing the SRQ line
to be asserted.

e A cable problem might exist involving the SRQ line.
Although the occurrence of ESRQ warns you of a definite GPIB problem,

it does not affect GPIB operations, except that you cannot depend on the
i bst a RQS bit while the condition lasts.

Check to see if other devices not used by your application are asserting
SRQ. Disconnect them from the GPIB if necessary.

Solutions

ETAB occurs only during the Fi ndLst n and Fi ndRQS functions. ETAB
indicates that there was some problem with atable used by these functions:

* Inthecase of Fi ndLst n, ETAB means that the given table did not
have enough room to hold all the addresses of the Listeners found.

* Inthecaseof Fi ndRQS, ETAB means that none of the devicesin the
given table were requesting service.

In the case of Fi ndLst n, increase the size of result arrays. In the case of
Fi ndRQS, check to seeif other devices not used by your application are
asserting SRQ. Disconnect them from the GPIB if necessary.
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Windows 98/95:
Troubleshooting and
Common Questions

This appendix describes how to troubleshoot problems and answers some
common questions about the NI-488.2 software for Windows 98/95.

Troubleshooting EDVR Error Conditions

In some cases, NI1-488.2 callsmay return with the ERR bit setini bst a and
thevalue EDVR ini berr. Thevalue stored ini bent | isuseful in
troubleshooting the error condition.

EDVR Error Condition with ibentl Set to 0xE028002C (-534249428)

If acall ismadewith aninterface number that iswithin the range of allowed
interface numbers (typically 0 to 3), but which has not been assigned to a
GPIB interface, an EDVR error condition occurswithi bent | set to
0xE028002C. You can assign an interface number to a GPIB interface by
configuring the N1-488.2 software and selecting an interface name. For
information about how to configure the NI1-488.2 software, refer to the
online help in the NI-488.2 Configuration utility, as follows:

1. Select Start»Programs»National Instruments NI-488.2»Explore
GPIB to start Measurement & Automation Explorer.

2. ExpandtheDevicesand I nterfacesdirectory by clicking onthe + next
to the folder.

3. Right-click on your GPIB interface and select Properties from the
drop-down menu that appears.

EDVR Error Condition with ibcntl Set to 0xE0140025 (—535560155)

If acall is made with an interface number that is not within the range of
allowed interface numbers (typically 0 to 3), an EDVR error condition
occurswithi bent | set to 0XE0140025.
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EDVR Error Condition with ibcntl Set to 0xE0140035 (—535560139)

If acall ismade with adevice namethat is not listed in the logical device
templatesthat are part of the NI1-488.2 Configuration utility, an EDVR error
condition occurswithi bent | set to 0xE0140035.

EDVR Error Condition with ibcntl Set to 0xE0320029 (-533594071) or
0xE1050029 (-519765975)

If acall is made with an interface number that is assigned to a GPIB
interface that is unusable because of aresource conflict, an EDVR error
condition occurswith i bent | set to 0XxE0320029 or 0xE1050029.

Thiserror isaso returned if you remove a PCMCIA-GPIB or
PCMCIA-GPIB+ while the driver is accessing it or if you try to

access a PCMCIA-GPIB when 32-bit PCMCIA drivers are not enabled.
To enable the 32-bit PCMCIA drivers, complete the following steps:

Select Start»Settings»Control Panel.
Double-click on the System icon.
Select the Performance tab.

If the PC Cards (PCM CIA) line does not read 32-bit, select
Start»Settings»Control Panel and double-click on the PC Card
(PCMCIA) icon.

The PC Card (PCMCIA) Wizard enables the 32-bit PCMCIA drivers.
5. Shut down your system and restart it.

Your system should detect your PCMCIA-GPIB or PCMCIA-GPIB+
interface.

EDVR Error Condition with ibcntl Set to 0xE0140004 (-535560188)

Thiserror might occur if the GPIB interface has not been correctly installed
and detected by Windows. For instructions on how to install the GPIB
hardware, refer to the GPIB Hardware Guide on the NI-488.2 for
Windows CD. For instructions on accessing this manual, refer to the
Using the NI-488.2 Documentation section in About This Manual.

EDVR Error Condition with ibcntl set to 0xE1030043 (—519897021)

Thiserror occursif you have enabled DOS NI-488.2 support and attempted
to run an existing N1-488.2 DOS application that was compiled with an
older, unsupported DOS language interface.

A w DD E
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Troubleshooting Device Manager Problems

If you are having trouble with your GPIB interface, use the Windows
Device Manager to troubleshoot your problems. To do so, complete the
following steps:

1. Select Start»Settings»Control Panel.
2. Double-click on the System icon.

3. Selectthe Device Manager tab and click onthe View deviceshy type
button.

4. Check toseeif theinterfacelistinginthe Device Manager appearswith
an exclamation point or X by it. If it does, click on theinterface listing
and then click on the Properties button to display the General
property tab for the interface.

5. IntheDevice Status section, look for the status description and status
code number. Use the status code descriptions and numbersin
Table D-1 to troubleshoot your problem.

Table D-1. Device Manager Status Codes

Code Problem Solution
9 Windows had a problem reading Contact National Instruments to upgrade
information from the GPIB interface. your GPIB interface.
This problem can occur if you are using
an older revision of the AT-GPIB/TNT+
or AT-GPIB/TNT (PnP) interface.
22 The GPIB interface is disabled. To enable the GPIB interface, check the
appropriate configuration checkbox in the
Device Usage section of the General tab.
24 The GPIB interfaceisnot present, or the | Select the interface in the Device Manager,
Device Manager is unaware that the and click on the Remove button. Next, click
GPIB interface is present. on the Refresh button. At this point, the
system rescans the installed hardware, and
the GPIB interface should show up without
any problems. If the problem persists, contact
National Instruments.
27 WindowswasunabletoassigntheGPIB | Free up system resources by disabling other

interface any resources. unnecessary hardware so that enough
resources are available for the GPIB
interface.
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Enabling Interrupts

In Windows 98/95, you can use your GPI B interface without interrupts, but
the NI-488.2 software performance is significantly slower without
interrupts. For example, transfer sizes between 1 and 10 bytestransfer at a
rate of only 2% of the transfer rate with enabled interrupts. Asthe transfer
size increases, the performance degradation decreases dightly, but it
remains a significant problem for all transfers under 1 Mbyte.

If you find the diminished performance unacceptable, complete the
following steps to free up an interrupt resource and configure your GPIB
interface to use the available interrupt resource.

Step 1. Free up an Interrupt Resource

To free up an interrupt resource, you must remove or disable one of the
other devicesin your system. If possible, remove a device in your system.
However, your system typically does not have any devices that can be
removed. In thiscase, you should disable adevice that you do not use, such
asLPT1 or COM1. To do so, complete the following steps:

1. Sdlect Start»Settings»Control Panel.
2. Double-click on the System icon.

3. SeecttheDevice Manager tab and click ontheView devicesby type
button.

If you do not use your LPT port, you can disable the LPT1 device and
if you do not use your COM port, you can disable the COM1 device.
However, do not disable a device that your system is using. You only
need to disable one device—either LPT1 or COM1.

4. Double-click onthe Ports (COM & LPT) item.

If the device you want to disable has a yellow exclamation mark (!)
overlaid onit, the device is not working properly and does not have
assigned resources. Disabling a device that is not working properly
does not free up an interrupt resource.

5. Double-click on the device that you want to
disable—Communications Port (COM1) or Printer Port (LPT1).

6. InthePropertiesdiaog box, check the Disable in this hardware
profile checkbox. If you are using Windows 95 version A, uncheck the
Original Configuration (Current) checkbox.
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7. Click onthe OK button to save your changes.

On the Device M anager tab, the disabled device hasared X overlaid
onit. Thered X indicates that the device is disabled.

Step 2. Remove Your GPIB Interface from the Device Manager

To remove your GPIB interface from the Device Manager, complete the

following steps:

1. OntheDevice Manager tab, double-click on the National
Instruments GPIB Interfacesitem. If you are removing a
PCMCIA-GPIB+ interface, double-click on the M ultifunction
Adaptersitem.

2. Click on the GPIB interface that does not have an interrupt resource
and click on the Remove button. If you are removing a
PCMCIA-GPIB+ interface, click on the NI PCM CIA-GPIB+
Multifunction Parent item and click on the Remove button.

Step 3. Refresh the Device Manager or Reinstall Your GPIB interface
On the Device Manager tab, click on the Refresh button.

If your GPIB interface doesnot appear under National | nstrumentsGPIB
I nterfaces, your GPIB interfaceisnot Plug and Play. In this case, you must
usethe Add GPIB Hardware Wizard to reinstall your interface. To start the
wizard, select Start»Programs»National Instruments NI-488.2»Add
GPIB Hardwar e and follow the instructions on the screen.

Common Questions

How do | get started?

To get started with your GPIB hardware and the NI1-488.2 software, usethe
NI-488.2 Getting Started Wizard. To do so, select Start»Programs»
National Instruments NI-488.2»Getting Started Wizard.

How do | troubleshoot problems?

Run the NI-488.2 Troubleshooting Wizard. To do so, select
Start»Programs»National | nstrumentsNI-488.2»Explore GPIB. Then,
select Help»Troubleshooting»NI-488.2 Troubleshooting Wizard.

© MNational Instruments Corporation D-5 NI-488.2 User Manual for Windows



Appendix D

Windows 98/95: Troubleshooting and Common Questions

How can | determine which version of the NI-488.2 software | have
installed?

To view the NI-488.2 software version, complete the following steps:

1. Sdlect Start»Programs»National I1nstruments NI-488.2»Explore
GPI B to start Measurement & Automation Explorer.

2. Select Help»About M easurement & Automation Explorer.

The Value column in the About M easurement & Automation
Explorer dialog box displays the version number of the NI1-488.2
software.

What do | doif my GPIB hardwareislisted in the Windows Device
Manager with acircled X or an exclamation point (!) overlaid on it?

Refer to the Troubleshooting Device Manager Problems section of this
appendix for information about what might cause this problem. If you
aready compl eted the troubl eshooting steps, contact National |nstruments.

How can | determine which type of GPIB hardware| haveinstalled?

Select Star t»Programs»National I nstrumentsNI-488.2»Explore GPIB
and expand the Devicesand I nterfaces directory by clicking on the + next
to the folder.

Measurement & Automation Explorer lists your installed GPIB hardware
under Devices and | nterfaces.

How many GPIB interfaces can | configurefor usewith the NI-488.2
software?

You can configure the NI-488.2 software to communicate with up to
100 GPIB interfaces.

How many devices can | configure for use with the NI-488.2 software?

You can configure the NI-488.2 software to use up to 1,024 logical devices.
The default number of devicesis 32. The maximum number of physical
devices you should connect to asingle GPIB interface is 14, or fewer,
depending on your system configuration.
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Areinterruptsand DMA required for the NI-488.2 softwar e?

Neither interruptsnor DMA arerequired. However, if you areusingaGPIB
interface with Analyzer capability (PCMCIA-GPIB+ or AT-GPIB/TNT+),
at least one interrupt level isrequired for the GPIB Analyzer driver.

In Windows 98/95, you can use your GPIB interface without interrupts, but
the NI-488.2 software performance is significantly slower without
interrupts. For example, transfer sizes between 1 and 10 bytestransfer at a
rate of only 2% of the transfer rate with enabled interrupts. Asthe transfer
size increases, the performance degradation decreases slightly, but it
remains a significant problem for al transfers under 1 Mbyte. For
instructions on how to assign an interrupt to your GPIB interfaceif onewas
not assigned, refer to the Enabling Interrupts section earlier in this
appendix.

How can | determineif my GPIB hardware and the NI-488.2 software
areinstalled properly?

Run the NI-488.2 Troubleshooting Wizard. To do so, select Start»
Programs»National | nstrumentsNI-488.2»Explore GPIB. Then, select
Help»Troubleshooting»NI-488.2 Troubleshooting Wizard.

When should | usethe Interactive Control utility?

You can use the Interactive Control utility to test and verify instrument
communication, troubleshoot problems, and develop your application.
For more information, refer to Chapter 6, Interactive Control Utility.

How do | use an NI-488.2 language inter face?

For information about using NI-488.2 language interfaces, refer to
Chapter 3, Developing Your NI-488.2 Application.

What do | need to know to communicate properly with my GPIB
instrument?

Refer to the documentation that came with your instrument. The command
sequences that you use depend on the specific instrument. The
documentation for each instrument should include the GPIB commands
that you need to communicate with your instrument. In most cases,
device-level traditional NI-488.2 cals are sufficient for communicating
with instruments. For more information, refer to Chapter 3, Developing
Your NI-488.2 Application.
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How can | start communicating with my GPIB instrument?

For simple instrument communication, use the N1-488.2 Communicator.
For instructions on how to use the NI-488.2 Communicator, refer to the
Basic Communication (Query/Write/Read) section in Chapter 2,
Measurement & Automation Explorer.

How do | check for errorsin my NI-488.2 application?

Examinethevalue of i bst a after each NI-488.2 call. If acal fails, the

ERR bit of i bst a isset and an error codeisstored ini ber r. For more

information about global status variables, refer to Chapter 4, Debugging
Your Application.

What information should | have before | call National | nstruments?

Before you call National Instruments, record the results of the NI-488.2
Troubleshooting Wizard. To start the NI-488.2 Troubleshooting Wizard,
select Start»Programs»National I nstrumentsNI-488.2»Explore GPIB.
Then, select Help»Troubleshooting»NI-488.2 Troubleshooting Wizard.
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Common Questions

This appendix answers some common questions about the NI-488.2
software for Windows 2000/NT.

Common Questions

How do | get started?

To get started with your GPIB hardware and the NI1-488.2 software, usethe
NI-488.2 Getting Started Wizard. To do so, select Star t»Programs»
National I nstruments NI-488.2»Getting Started Wizard.

How do | troubleshoot problems?

Run the NI-488.2 Troubleshooting Wizard. To do so, select
Star t»Programs»National | nstrumentsNI-488.2»Explore GPIB. Then,
select Help»Troubleshooting»NI1-488.2 Troubleshooting Wizar d.

How can | determine which version of the NI-488.2 software | have
installed?

To view the NI-488.2 software version, complete the following steps:

1. Select Start»Programs»National Instruments NI-488.2»Explore
GPIB to start Measurement & Automation Explorer.

2. Select Help»About Measurement & Automation Explorer.

The Value column in the About M easurement & Automation
Explorer dialog box displays the version number of the NI-488.2
software.

© MNational Instruments Corporation E-1 NI-488.2 User Manual for Windows



Appendix E

Windows 2000/NT: Common Questions

How can | determine which type of GPIB hardware | haveinstalled?

Select Star t»Programs»National I nstrumentsNI-488.2»Explore GPIB
and expand the Devicesand | nter facesdirectory by clicking on the + next
to the folder.

Measurement & Automation Explorer lists your installed GPIB hardware
under Devices and I nterfaces.

How many GPIB interfaces can | configurefor use with the NI1-488.2
software?

You can configure the NI-488.2 software to communicate with up to four
GPIB interfaces.

How many devices can | configure for use with the NI-488.2 software?

You can configure the NI-488.2 software to use up to 100 logical devices.
The default number of devicesis 32.

Areinterruptsand DMA required with the NI-488.2 softwar e?
Interrupts are required, but DMA is not.

How can | determineif my GPIB hardware and the NI-488.2 software
areinstalled properly?

Run the NI-488.2 Troubleshooting Wizard. To do so, select Start»
Programs»National | nstrumentsNI-488.2»Explore GPIB. Then, select
Help»Troubleshooting»NI-488.2 Troubleshooting Wizar d.

How can | start communicating with my GPIB instrument?

For simple instrument communication, use the N1-488.2 Communicator.
For instructions on how to use the NI-488.2 Communicator, refer to the
Basic Communication (Query/\Write/Read) section in Chapter 2,
Measurement & Automation Explorer.

When should | usethe Interactive Control utility?

You can use the Interactive Control utility to test and verify instrument
communication, troubleshoot problems, and develop your application.
For more information, refer to Chapter 6, Interactive Control Utility.
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How do | use an NI-488.2 language interface?

For information about using NI-488.2 language interfaces, refer to
Chapter 3, Developing Your NI-488.2 Application.

What do | need to know to communicate properly with my GPIB
instrument?

Refer to the documentation that came with your instrument. The command
sequences that you use depend on the specific instrument. The
documentation for each instrument should include the GPIB commands
that you need to communicate with your instrument. In most cases,
device-level traditional NI1-488.2 calls are sufficient for communicating
with instruments. For more information, refer to Chapter 3, Developing
Your NI-488.2 Application.

How do | check for errorsin my NI-488.2 application?

Examinethevalue of i bst a after each NI1-488.2 call. If acall fails, the
ERR bit of i bst a isset and an error codeisstored ini ber r. For more
information about global status variables, refer to Chapter 4, Debugging
Your Application.

What information should | have beforel call National I nstruments?

Before you call National Instruments, record the results of the NI-488.2
Troubleshooting Wizard. To start the NI1-488.2 Troubleshooting Wizard,
select Start»Programs»National I nstrumentsNI-488.2»Explore GPIB.
Then, select Help»Troubleshooting»NI-488.2 Troubleshooting Wizard.
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Technical Support Resources

This appendix describes the comprehensive resources available to you in
the Technical Support section of the National Instruments Web site and
provides technical support telephone numbers for you to use if you have
trouble connecting to our Web site or if you do not have internet access.

NI Web Support

To provide you with immediate answers and solutions 24 hours a day,
365 daysayear, National Instruments maintains extensive online technical
support resources. They are available to you at no cost, are updated daily,
and can be found in the Technical Support section of our Web site at

www. nat i nst. com support .

Online Problem-Solving and Diagnostic Resources

* KnowledgeBase—A searchable database containing thousands of
frequently asked questions (FAQS) and their corresponding answers or
solutions, including special sections devoted to our newest products.
Thedatabaseisupdated daily in response to new customer experiences
and feedback.

*  Troubleshooting Wizar ds—Step-by-step guides lead you through
common problems and answer questions about our entire product line.
Wizards include screen shots that illustrate the steps being described
and provide detailed information ranging from simple getting started
instructions to advanced topics.

e Product Manuals—A comprehensive, searchable library of the latest
editions of National Instruments hardware and software product
manuals.

e Hardware Reference Database—A searchable database containing
brief hardware descriptions, mechanical drawings, and helpful images
of jumper settings and connector pinouts.

* Application Notes—A library with more than 100 short papers
addressing specific topics such as creating and calling DLLS,
developing your own instrument driver software, and porting
applications between platforms and operating systems.
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Software-Related Resources

e Instrument Driver Networ k—A library with hundreds of instrument
driversfor control of standalone instrumentsvia GPIB, VXI, or serid
interfaces. You also can submit arequest for a particular instrument
driver if it does not already appear in the library.

« Example Programs Database—A database with numerous,
non-shipping example programs for National Instruments
programming environments. You can use them to complement the
example programsthat are already included with National Instruments
products.

e SoftwareLibrary—A library with updates and patchesto application
software, links to the latest versions of driver software for National
Instruments hardware products, and utility routines.

Worldwide Support

National Instruments has offices located around the globe. Many branch
offices maintain a Web site to provide information on local services. You
can access these Web sites from www. nat i nst . contf wor | dwi de.

If you have trouble connecting to our Web site, please contact your local
National Instruments office or the source from which you purchased your
National Instruments product(s) to obtain support.

For telephone support in the United States, dial 512 795 8248. For
telephone support outside the United States, contact your local branch
office:

Australia 03 9879 5166, Austria 0662 45 79 90 0, Belgium 02 757 00 20,
Brazil 011 284 5011, Canada (Ontario) 905 785 0085,

Canada (Québec) 514 694 8521, China 0755 3904939,

Denmark 45 76 26 00, Finland 09 725 725 11, France 01 48 14 24 24,
Germany 089 741 31 30, Hong Kong 2645 3186, India 91805275406,
Isragl 03 6120092, Italy 02 413091, Japan 03 5472 2970,

Korea 02 596 7456, Mexico (D.F.) 5 280 7625,

Mexico (Monterrey) 8 357 7695, Netherlands 0348 433466,

Norway 32 27 73 00, Singapore 2265886, Spain (Madrid) 91 640 0085,
Spain (Barcelona) 93 582 0251, Sweden 08 587 895 00,

Switzerland 056 200 51 51, Taiwan 02 2377 1200,

United Kingdom 01635 523545
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Prefix Meaning Value
n- nano- 10-°
m- milli- 10-3
M- mega- 108
A
acceptor handshake Listeners use this GPIB interface function to receive data, and all devices
use it to receive commands. See source handshake and handshake.
access board The GPIB board that controls and communicates with the devices on the
bus that are attached to it.
ANSI American National Standards Institute.
AP Application Programming Interface
ASCII American Standard Code for Information Interchange.
asynchronous An action or event that occurs at an unpredictable time with respect to the

automatic seria
polling

base 1/0 address
BIOS

board-level function

© MNational Instruments Corporation G-1

execution of a program.

A feature of the GPIB software in which serial polls are executed
automatically by the driver whenever a device asserts the GPIB SRQ line.
Also called autopolling.

See I/O address.
Basic Input/Output System.

A rudimentary function that performs a single operation.
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C

CFE Configuration Enable. The GPIB command which precedes CFGnh and is
used to place devicesinto their configuration mode.

CFGn These GPIB commands (CFGL1 through CFG15) follow CFE and are used
to configure al devices for the number of meters of cable in the system so
H$S488 transfers occur without errors.

CiC Controller-In-Charge. The device that manages the GPIB by sending
interface messages to other devices.

CPU Central processing unit.

D

DAV Data Valid. One of the three GPIB handshake lines. See handshake.

DCL Device Clear. The GPIB command used to reset the device or internal
functions of all devices. See SDC.

device-level function A function that combines several rudimentary board operationsinto one
function so that the user does not have to be concerned with bus
management or other GPIB protocol matters.

DIO1 through DIO8 The GPIB linesthat are used to transmit command or data bytes from one
device to another.

DLL Dynamic link library.

DMA Direct memory access. High-speed data transfer between the GPIB board
and memory that isnot handled directly by the CPU. Not available on some
systems. See programmed 1/O.

driver Device driver software installed within the operating system.

E

END or END Message A message that signals the end of adata string. END is sent by asserting
the GPIB End or Identify (EOI) line with the last data byte.

EQI A GPIB line that signals either the last byte of a data message (END) or
the parallel poll Identify (IDY) message.
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EOS or EOS Byte

EOT

ESB

FIFO

GET

GPIB

GPIB address

GPIB board

GTL

H

handshake

© MNational Instruments Corporation G-3
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A 7- or 8-bit end-of-string character that is sent as the last byte of a data
message.

End of transmission.

The Event Status bit. Part of the IEEE 488.2-defined status byte which is
received from a device responding to a serial poll.

First-in-first-out.

Group Execute Trigger. The GPIB command used to trigger a device or
internal function of an addressed Listener.

General Purpose Interface Bus is the common name for the
communications interface system defined in ANSI/IEEE
Standard 488.1-1987 and ANSI/IEEE Standard 488.2-1992.

The address of a device on the GPIB, composed of a primary address
(MLA and MTA) and perhaps a secondary address (MSA). The GPIB
board has both a GPIB address and an /O address.

Refers to the National Instruments family of GPIB interfaces.

Go To Local. The GPIB command used to place an addressed Listener in
local (front panel) control mode.

The mechanism used to transfer bytes from the source handshake function
of one device to the acceptor handshake function of another device. DAV,

NRFD, and NDAC, three GPIB lines, are used in an interlocked fashion to
signal the phases of the transfer, so that bytes can be sent asynchronously

(for example, without a clock) at the speed of the slowest device.

For moreinformation about handshaking, refer to the ANSI/IEEE Standard
488.1-1987.
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hex

high-level function

HSA488

Hz

i bent

i bentl

i berr

i bsta

IEEE

interface message

110

1/0O address

Hexadecimal; anumber represented in base 16. For example, decimal 16is
hex 10.

See device-level function.

A high-speed data transfer protocol for |EEE 488. This protocol increases
performance for GPIB reads and writes up to 8 Mbytes/s, depending on
your system.

Hertz.

After each NI-488.2 1/0 call, this global variable contains the actual
number of bytes transmitted. On systems with a 16-hit integer, such as
MS-DOS, i bent isal6-bitinteger, andi bent | isa32-bit integer. For
cross-platform compatibility, usei bent | .

After each NI-488.2 1/0 call, this global variable contains the actual
number of bytes transmitted. On systems with a 16-bit integer, such as
MS-DOS, i bent isa16-bitinteger, andi bent | isa32-bit integer. For
cross-platform compatibility, usei bent | .

A global variable that contains the specific error code associated with a
function call that failed.

At the end of each function call, thisglobal variable (status word) contains
status information.

Ingtitute of Electrical and Electronic Engineers.

A broadcast message sent from the Controller to al devices and used to
manage the GPIB.

Input/output. In this manual, it is the transmission of commands or
messages between the system viathe GPIB board and other devices on the
GPIB.

The address of the GPIB board from the point of view of the CPU, as
opposed to the GPIB address of the GPIB board. Also called port address
or board address.

NI-488.2 User Manual for Windows G-4 www.natinst.com



i st

L

LAD

language interface

Listener

LLO

low-level function

m

MAV

MLA

MSA

MTA

multitasking

Glossary

Industry Standard Architecture.

An Individual Status bit of the status byte used in the Parallel Poll
Configure function.

Listen Address. See MLA.

Code that enables an application program that uses N1-488.2 callsto access
the driver.

A GPIB device that receives data messages from a Talker.

Local Lockout. The GPIB command used to tell all devicesthat they may
or should ignore remote (GPIB) data messages or local (front panel)
controls, depending on whether the deviceisin local or remote program
mode.

A rudimentary board or device function that performs a single operation.

Meters.

The Message Available bit is part of the |EEE 488.2-defined status byte
which isreceived from a device responding to a serial poll.

My Listen Address. A GPIB command used to address adeviceto be a
Listener. It can be any one of the 31 primary addresses.

My Secondary Address. The GPIB command used to addressadeviceto be
aListener or a Talker when extended (two-byte) addressing is used. The
complete addressisaMLA or MTA address followed by an MSA address.
There are 31 secondary addresses for atotal of 961 distinct listen or talk
addresses for devices.

My Talk Address. A GPIB command used to address adeviceto be a
Talker. It can be any one of the 31 primary addresses.

The concurrent processing of more than one program or task.
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N

NDAC Not Data Accepted. One of the three GPIB handshake lines. See handshake.

NRFD Not Ready For Data. One of the three GPIB handshake lines.

See handshake.

P

parale poll The process of polling al configured devices at once and reading a
composite poll response. See serial poll.

PC Personal computer.

PCI Peripheral Component Interconnect.

PIO See programmed 1/O.

PPC Parallel Poll Configure. The GPIB command used to configure an
addressed Listener to participate in polls.

PPD Parallel Poll Disable. The GPIB command used to disable a configured
device from participating in polls. There are 16 PPD commands.

PPE Parallel Poll Enable. The GPIB command used to enable a configured
device to participate in polls and to assign a DIO response line. There
are 16 PPE commands.

PPU Parallel Poll Unconfigure. The GPIB command used to disable used to
disable any device from participating in polls.

programmed /O L ow-speed data transfer between the GPIB interface and memory in
which the CPU moves each data byte according to program instructions.
See DMA.

R

resynchronize The GPIB software and the user application must resynchronize after
asynchronous |/O operations have completed.

RQS Request Service.
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SDC

semaphore

seria poll

service regquest

source handshake

SPD

SPE

SRQ

status byte

status word

synchronous

System Controller
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Glossary

Seconds.

Selected Device Clear. The GPIB command used to reset internal or device
functions of an addressed Listener. See DCL.

An object that maintains a count between zero and some maximum value,
limiting the number of threads that are simultaneously accessing a shared
resource.

The process of polling and reading the status byte of one device at atime.
See paralld poll.

See SRQ.

The GPIB interface function that transmits dataand commands. Talkersuse
this function to send data, and the Controller usesit to send commands.
See acceptor handshake and handshake.

Seria Poll Disable. The GPIB command used to cancel an SPE command.

Seria Poll Enable. The GPIB command used to enabl e a specific deviceto
be polled. That device must also be addressed to talk. See SPD.

Service Request. The GPIB linethat adevice assertsto notify the CIC that
the device needs servicing.

The | EEE 488.2-defined data byte sent by a devicewhen it is serially
polled.

Seei bst a.

Refersto the relationship between the GPIB driver functions and a process
when executing driver functionsis predictable; the processis blocked until
the driver completes the function.

The single designated Controller that can assert control (become CIC of the
GPIB) by sending the Interface Clear (IFC) message. Other devices can
become CIC only by having control passed to them.
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Glossary

T

TAD
Taker

TCT

timeout

TLC

ud

UNL

UNT

Talk Address. See MTA.
A GPIB device that sends data messagesto Listeners.

Take Control. The GPIB command used to pass control of the busfrom the
current Controller to an addressed Talker.

A feature of the GPIB driver that prevents I/O functions from hanging
indefinitely when there is a problem on the GPIB.

Anintegrated circuit that implements most of the GPIB Talker, Listener,
and Controller functions in hardware.

Unit descriptor. A variable name and first argument of each function call
that containsthe unit descriptor of the GPIB interface or other GPIB device
that is the object of the function.

Unlisten. The GPIB command used to unaddress any active Listeners.

Untalk. The GPIB command used to unaddress an active Talker.
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Index

Numbers/Symbols

I (repeat previous function) function, Interactive
Control utility, 6-9

$ filename (execute indirect file) function,
Interactive Control utility, 6-10

+ (turn ON display) function, Interactive Control
utility, 6-10

- (turn OFF display) function, Interactive
Control utility, 6-9

A

active Controller, A-1
addresses. See GPIB addresses.
AllSpall routine, 7-15, 7-16
application development. See also debugging;
NI-488.2 programming techniques.
accessing NI-488.2 driver, 3-3
checking status with global variables,
3-5t03-7
count variables (ibent and ibentl), 3-7
error variable (iberr), 3-7
status word (ibsta), 3-5to 3-7
choosing programming methodology
accessing NI-488.2 driver, 3-3
communicating with single GPIB
device, 3-4t0 3-5
direct entry access, 3-3
multiple interfaces and/or multiple
devices, 3-5
NI-488.2 language interfaces, 3-3
selecting NI-488.2 API subset,
3-41t03-5
communicating with instruments
multiple interfaces or multiple
devices, 3-5
single GPIB device, 3-4to 3-5

© MNational Instruments Corporation

I-1

using Interactive Control utility, 3-7
using NI-488.2 Communicator,
3-1to3-2
interactive instrument control, 3-2 to 3-3
language-specific instructions, 3-12 to 3-16
Borland C/C++, 3-12
direct entry with C, 3-13to 3-16
directly accessing gpib-32.dll
exports, 3-14 to 3-16
gpib-32.dll exports, 3-13 to 3-14
Microsoft Visual Basic, 3-13
Microsoft Visual C/C++, 3-12
programming models
multiple interfaces or multiple GPIB
devices, 3-10to 3-12
single GPIB device, 3-8t0 3-9
simple instrument control, 3-1 to 3-2

application programming models

multiple interfaces or multiple GPIB
devices, 3-10to 3-12
becoming Controller-In-Charge, 3-10
communicating with devices,
3-11t0 3-12
determining GPIB address of
device, 3-11
general steps and examples,
3-10t0 3-12
initialization, 3-10
initializing devices, 3-11
itemsto include, 3-10
placing device offline, 3-12
single GPIB device, 3-8t0 3-9
clearing device, 3-9
communicating with device, 3-9
general steps and examples, 3-8 to 3-9
initialization, 3-8 to 3-9
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Index

itemsto include, 3-8
placing device offline before
exiting, 3-9
applications, existing. See existing
applications, running.
asynchronous event notification in Win32
applications, 7-4to 7-9
calling ibnotify function, 7-4 to 7-5
ibnotify programming example,
7-5t0 7-9
ATN (attention) line (table), A-3
ATN status word condition
bit position, hex value, and type
(table), 3-6
description, B-4
automatic serial polling. See seria polling.
auxiliary functions, Interactive Control utility,
6-9t0 6-10

board calls. See NI-488.2 cdls.

Borland C/C++ programming
instructions, 3-12

buffer option function, Interactive Control
utility, 6-10

bus management and device-level cals, 7-11

C
C language
Borland C/C++ programming
instructions, 3-12
direct entry for application development,
3-13t0 3-16
directly accessing gpib-32.dl|
exports, 3-15to0 3-16
gpib-32.dll exports, 3-13to 3-14
Microsoft Visual C/C++ programming
instructions, 3-12
cable length for high-speed data transfers,
7-2t0 7-3
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CIC. See Controller-in-Charge (CIC).
CIC Protocaol, 7-11
CIC status word condition
bit position, hex value, and type
(table), 3-6
description, B-4
CMPL status word condition
bit position, hex value, and type
(table), 3-6
description, B-3
common questions. See troubleshooting and
common questions.
communicating with instruments
multiple interfaces or multiple
devices, 3-5
simple instrument control, 3-1 to 3-2
single GPIB device, 3-4to 3-5
using Interactive Control utility, 3-7
using Measurement & Automation
Explorer, 2-6 to 2-8
advanced communication, 2-7 to 2-8
basic communication, 2-6 to 2-7
using N1-488.2 Communicator, 3-1 to 3-2
communication errors, 4-5
repeat addressing, 4-5
termination method, 4-5
configuration, 1-1 to 1-3. See also Interactive
Control utility.
controlling more than one interface, 1-2
linear and star system configuration
(figure), 1-1
requirements, 1-2 to 1-3
system configuration effects on
H$488, 7-3
configuration errors, 4-3
Configure (CFGn) message, 7-3
Configure Enable (CFE) message, 7-3
Controller-in-Charge (CIC)
active or inactive, A-1
making GPIB board CIC, 3-10, 7-11
System Controller as CIC, A-1
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Controllers
definition, A-1
monitoring by Talker/Listener

applications, 7-11to 7-12

System Controller, A-1

count information, in Interactive Control

utility, 6-11
count variables (ibcnt and ibentl), 3-7

D

datalines, A-2
datatransfers
high-speed (H$488), 7-2to 7-3
enabling, 7-2to 7-3
system configuration effects, 7-3
terminating, 7-1 to 7-2
DAYV (datavalid) line (table), A-3
DCAS status word condition
bit position, hex value, and type
(table), 3-6
description, B-5
Talker/Listener applications, 7-12
debugging. See also NI Spy utility;
troubleshooting and common questions.
communication errors, 4-5
repeat addressing, 4-5
termination method, 4-5
configuration errors, 4-2
global status variables, 4-2
GPIB error codes (table), C-1
other errors, 4-5
timing errors, 4-4
DevClearList function, D-11
device calls. See NI-488.2 calls.
device-level calls and bus management, 7-11
Device Manager device status codes,
troubleshooting, D-3
diagnostic resources, online, F-1
direct access to N1-488.2 dynamic link
library, 3-3
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documentation
accessing N1-488.2 Online Help, xi
conventions used in manual, xii
related documentation, xii
using NI-488.2 documentation, xi
DOS NI-488.2 applications
enabling/disabling support
Windows 98/95, 2-13 to 2-14
Windows 2000/NT, 2-14
running
under Windows 98/95, 3-17
under Windows 2000/NT, 3-18
DTAS status word condition
bit position, hex value, and type
(table), 3-6
description, B-5
Talker/Listener applications, 7-12
dynamic link library, GPIB. See
NI-488.2 DLL.

E

EABO error code, C-5
EADR error code, C-4
EARG error code, C-4
EBUS error code, C-8
ECAP error code, C-7
ECIC error code, C-2to C-3
EDMA error code, C-6
EDVR error code
description, C-2
troubleshooting, D-1to D-2
EFSO error code, C-7
end-of-string character. See EOS.
END status word condition
bit position, hex value, and type
(table), 3-6
description, B-2
ENEB error code, C-5to C-6
ENOL error code, C-3
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EQI (end or identify) line
purpose (table), A-3
termination of datatransfers, 7-1

EOIP error code, C-6to C-7

EOS
configuring EOS mode, 7-1 to 7-2
EOS comparison method, 7-1
EOS read method, 7-2
EOS write method, 7-1

ERR status word condition
bit position, hex value, and type

(table), 3-6
description, B-2

error codes and solutions
EABO, C-5
EADR, C-4
EARG, C-4
EBUS, C-8
ECAP, C-7
ECIC,C-2t0 C-3
EDMA, C-6
EDVR, C-2, D-1to D-2
EFSO, C-7
ENEB, C-5to C-6
ENOL, C-3
EQIP, C-6to C-7
ESAC, C-5
ESRQ, C-8to C-9
ESTB, C-8
ETAB, C-9
GPIB error codes (table), C-1

error conditions
communication errors, 4-5

repeat addressing, 4-5
termination method, 4-5
configuration errors, 4-3
Interactive Control utility error
information, 6-10 to 6-11
timing errors, 4-4
error variable (iberr), 3-7
ESAC error code, C-5
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ESRQ error code, C-8to C-9
ESTB error code, C-8
ETAB error code, C-9
event notification. See asynchronous event
notification in Win32 applications.
Event Status bit (ESB), 7-12to 7-13
execute function n times (n *) function,
Interactive Control utility, 6-10
execute indirect file ($) function, Interactive
Control utility, 6-10
execute previous function ntimes (n* 1)
function, Interactive Control utility, 6-10
existing applications, running
DOS NI-488.2 applications
Windows 98/95, 3-17
Windows 2000/NT, 3-18
Win32 and Win16 NI-488.2
applications, 3-17

F

FindLstn function, 3-11
FindRQS function, 7-15, 7-16

G

General Purpose Interface Bus. See GPIB.
global variables, 3-5to 3-7
count variables (ibcnt and ibentl), 3-7
debugging applications, 4-2
error variable (iberr), 3-7
status word (ibsta), 3-5to 3-7
writing multithread Win32 GPIB
applications, 7-9 to 7-10
GPIB
configuration, 1-1to 1-3. See also
Interactive Control utility.
controlling more than one board, 1-2
linear and star system configuration
(figure), 1-1
reguirements, 1-2 to 1-3

www.natinst.com



definition, A-1
overview, A-1
sending messages across, A-2to A-3
datalines, A-2
handshake lines, A-3
interface management lines, A-3
Talkers, Listeners, and Controllers, A-1
gpib-32.dll exports
accessing directly, 3-14 to 3-16
direct entry with C, 3-13to 3-14
GPIB addresses
address bit configuration (figure), A-2
primary and secondary, A-2
repeat addressing, 4-5
syntax in Interactive Control utility, 6-5
GPIB device templates, changing
Windows 98/95, 2-12
Windows 2000/NT, 2-13
GPIB-ENET network settings, viewing or
changing, 2-15 to 2-16
assigning IP address, 2-15
configuring advance | P settings,
2-15t02-16
updating GPIB-ENET firmware, 2-16
GPIB instruments. See also communicating
with instruments.
Instruments Enumeration Failed
message, 2-6
Instruments not Found message, 2-6
scanning for, 2-5 to 2-6
viewing information about, 2-11 to 2-12
GPIB interface
adding new, 2-4 to 2-5
deleting, 2-5
viewing or changing settings, 2-9 to 2-11
Windows 98/95, 2-9 to 2-10
Windows 2000/NT, 2-10 to 2-11
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H

handshake lines, A-3
help. See online help.
Help (display Interactive Control utility online
help) function (table), 6-9
Help option function, Interactive Control
utility, 6-9
high-speed data transfers (H$488), 7-2to 7-3
cable length, 7-2, 7-3
enabling H$488, 7-2 to 7-3
system configuration effects, 7-3
H$488. See high-speed data transfers
(H$488).
HSS488 configuration message, 7-3

ibask function, 7-3
ibclr function
clearing devices, 3-9
using in Interactive Control utility
(example), 6-3
ibent and ibentl variables, 3-7
ibconfig function
changing cable length, 7-3
determining assertion of EQI line, 7-2
enabling autopolling, 7-13
enabling high-speed data transfers,
7-2t0 7-3
ibdev function
opening devices, 3-8
using in Interactive Control utility
(example), 6-2
ibeos function, 7-1
ibeot function, 7-1
iberr error variable, 3-7
ibnotify function
asynchronous event notification example,
7-5t0 7-9
caling, 7-4to 7-5
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ibonl function
placing device offline, 3-9, 3-12
using in Interactive Control utility
(example), 6-3t0 6-4
ibppc function, 7-17 to 7-18
ibrd function
reading response from device, 3-9
using in Interactive Control utility
(example), 6-3
ibrpp function, 7-18
ibrsp function
automatic serial polling, 7-13
SRQ and seria polling, 7-14
ibsta. See status word (ibsta).
ibwait function
Talker/Listener applications, 7-11
terminating stuck SRQ state, 7-13
waiting for GPIB conditions, 7-4
ibwrt function
sending *IDN? query to device, 3-9
using in Interactive Control utility
(example), 6-3
IFC (interface clear) line, A-3
instruments. See communicating with
instruments; GPIB instruments.
Interactive Control utility
auxiliary functions (table), 6-9 to 6-10
communicating with instruments,
3-2t03-3
count, 6-11
error information, 6-10 to 6-11
getting started, 6-1to 6-4
NI-488 function examples, 6-2 to 6-4
overview, 6-1
programming considerations, 3-2 to 3-3
status word, 6-10
syntax, 6-4 to 6-10
addresses, 6-5
board-level traditional NI-488.2 calls
(table), 6-7 to 6-8
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device-level traditional NI-488.2
cals (table), 6-5to 6-6
multi-device NI-488.2 calls (table),
6-8t06-9
numbers, 6-4
strings, 6-4 to 6-5
interface management lines, A-3
interrupts
autopolling and interrupts, 7-14
enabling in Windows 98/95, D-4 to D-5

L

LACS status word condition
bit position, hex value, and type
(table), 3-6
description, B-5
Talker/Listener applications, 7-12
language interfaces, 3-3
listen address, A-2
Listeners, A-1. See also Talker/Listener
applications.
LOK status word condition
bit position, hex value, and type
(table), 3-6
description, B-3

manual. See documentation.
Measurement & Automation Explorer,
2-1t02-16
accessing additional help and resources,
2-14t0 2-15
National Instruments GPIB Web
site, 2-15
NI-488.2 online help, 2-14 to 2-15
adding new GPIB interface, 2-4 to 2-5
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changing GPIB device templates,
2-12t02-13
Windows 98/95, 2-12
Windows 2000/NT, 2-13
communicating with instrument,
2-6t02-8
deleting GPIB interface, 2-5
enabling/disabling N1-488.2 DOS
support, 2-13 to 2-14
Windows 98/95, 2-13 to 2-14
Windows 2000/NT, 2-13 to 2-14
getting started, 2-2 to 2-3
monitoring, recording, and displaying
NI-488.2 calls, 2-8 to 2-9
overview, 2-1
scanning for GPIB instruments, 2-5 to 2-6
starting, 2-2
troubleshooting NI1-488.2 problems, 2-4
viewing GPIB instrument information,
2-11to0 2-12
viewing NI-488.2 software version, 2-8
viewing or changing GPIB-ENET
network settings, 2-15 to 2-16
assigning IP address, 2-15
configuring advance | P settings,
2-15t0 2-16
updating GPIB-ENET
firmware, 2-16
viewing or changing GPIB interface
settings, 2-9to 2-11
Windows 98/95, 2-9 to 2-10
Windows 2000/NT, 2-10 to 2-11
Message Available (MAV) hit, 7-12
messages, sending across GPIB, A-2to A-3
datalines, A-2
handshake lines, A-3
interface management lines, A-3
Microsoft Visual Basic programming
instructions, 3-13
Microsoft Visual C/C++ programming
instructions, 3-12
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Microsoft Windows. See Windows 98/95;
Windows 2000/NT.

multi-device NI-488.2 calls. See
NI-488.2 cdls.

multiple interfaces or multiple devices, 3-5

multithreaded Win32 GPIB applications,
writing, 7-9to 7-10

n* ! (execute previous function n times)
function, Interactive Control utility, 6-10
n* (execute function n times) function,
Interactive Control utility, 6-10
National Instruments Web support, F-1 to F-2
NDAC (not data accepted) line (table), A-3
NI-488.2 cals
device-level callsand bus
management, 7-11
examplesin Interactive Control utility,
6-1to 6-4
Interactive Control utility syntax
board-level calls (table), 6-7 to 6-8
device-level traditional calls (table),
6-5t0 6-6
multi-device calls (table), 6-8 to 6-9
monitoring, recording, and displaying,
2-8t02-9
parallel polling
device-level traditional calls,
7-18to 7-19
multi-device calls, 7-19
traditional device-level calls,
7-17t0 7-18
SRQ and serial polling
device-level traditiona calls,
7-14t0 7-15
examples, 7-16 to 7-17
multi-device calls, 7-15
NI-488.2 Communicator, 3-1

NI-488.2 User Manual for Windows



Index

NI-488.2 DLL
choosing access method, 3-3
direct entry access, 3-3
NI-488.2 language interfaces, 3-3
NI-488.2 DOS support. See DOS NI-488.2
applications.
NI-488.2 programming techniques. See also
application devel opment.
asynchronous event notificationin Win32
applications, 7-4 to 7-9
calling ibnotify function, 7-4 to 7-5
ibnotify programming example,
7-5t0 7-9
device-level calls and bus
management, 7-11
high-speed data transfers, 7-2 to 7-3
enabling H$488, 7-2 to 7-3
system configuration effects, 7-3
parald polling, 7-17 to 7-19
implementing, 7-17 to 7-18
multi-device N1-488.2 calls, 7-19
traditional NI-488.2 calls,
7-17t0 7-18
serial polling, 7-12 to 7-17
automatic serial polling, 7-13to 7-14
autopolling and interrupts, 7-14
stuck SRQ state, 7-13
service requests
from |EEE 488 devices, 7-12
from |EEE 488.2 devices, 7-12
SRQ and serial polling
with device-level traditional
NI-488.2 calls,
7-14t0 7-15
with multi-device NI-488.2 cadlls,
7-15to 7-17
Talker/Listener applications, 7-11 to 7-12
termination of datatransfers, 7-1to 7-2
waiting for GPIB conditions, 7-4
writing multithread Win32 GPIB
applications, 7-9to 7-10
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NI-488.2 software

language interfaces, 3-3

viewing version, 2-8
NI Spy utility

debugging applications, 4-1

exiting, 5-3

locating errors, 5-2

online help, 5-2

overview, 5-1

performance considerations, 5-3

starting, 5-1 to 5-2

viewing properties for recorded calls, 5-2
NRFD (not ready for data) line (table), A-3
number syntax, in Interactive Control

utility, 6-4

0

online help
accessing, Xi
NI-488.2 online help, 2-14 to 2-15
NI Spy online help, 5-2
online problem-solving and diagnostic
resources, 2-15, F-1

P

parallel polling, 7-17 to 7-19
implementing, 7-17 to 7-19
using NI1-488.2 calls, 7-17 to 7-19
multi-device, 7-19
traditional, 7-17 to 7-18
PPoll routine, 7-19
PPollConfig routine, 7-19
PPollUnconfig routine, 7-19
primary GPIB address, A-2
problem solving. See debugging;
troubleshooting and common questions.
programming. See application devel opment;
debugging; NI-488.2 programming
techniques.

www.natinst.com



Q

g function, Interactive Control utility, 6-10

R

ReadStatusByte routine, 7-15
Receive function, 3-12
REM status word condition
bit position, hex value, and type
(table), 3-6
description, B-4
REN (remote enable) line (table), A-3
repeat addressing, 4-5
repeat previous function (1) function,
Interactive Control utility, 6-9
requesting service. See service requests.
RQS status word condition
bit position, hex value, and type
(table), 3-6
description, B-3
running existing applications. See existing
applications, running.

S

secondary GPIB address, A-2
SendI FC routine, 3-10
SendList function, 3-12
serial polling, 7-12 to 7-17
application example using N1-488.2
routines, 7-16 to 7-17
automatic seria polling, 7-13to 7-14
autopolling and interrupts, 7-14
stuck SRQ state, 7-13
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service requests
from |EEE 488 devices, 7-12
from |EEE 488.2 devices, 7-12
SRQ and serial polling
device-level traditional NI1-488.2
calls, 7-14 to 7-15
multi-device NI-488.2 calls,
7-15t0 7-17
service requests
serial polling
|EEE 488 devices, 7-12
|EEE 488.2 devices, 7-12
stuck SRQ state, 7-13
set 488.2 v function, Interactive Control
utility, 6-9
set udname function, Interactive Control
utility, 6-9
setting up your system. See configuration.
software-related resources, F-2
SRQ (service request) line
purpose (table), A-3
serial polling
automatic serial polling, 7-13 to 7-14
using device-level traditional
NI-488.2 cdls, 7-14 to 7-15
using multi-device NI-488.2 calls,
7-15t0 7-17
stuck SRQ state, 7-13
SRQI status word condition
bit position, hex value, and type
(table), 3-6
description, B-3
status word (ibsta), 3-5to 3-7
ATN, B-4
CIC,B-4
CMPL, B-3
DCAS, 7-12, B-5
DTAS, 7-12, B-5
END, B-2
ERR, B-2
Interactive Control utility example, 6-10
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LACS, 7-12, B-5
LOK, B-3
programming considerations, 3-5to 3-7
REM, B-4
RQS, B-3
SRQI, B-3
status word layout (table), 3-6, B-1
TACS, 7-12, B-4
TIMO, B-2
string syntax, in Interactive Control utility,
6-4t0 6-5
stuck SRQ state, 7-13
System Controller, A-1

T

TACS status word condition
bit position, hex value, and type
(table), 3-6
description, B-4
Talker/Listener applications, 7-12
talk address, A-2
Talker/Listener applications, 7-11 to 7-12
Takers, A-1
technical support resources, F-1 to F-2
termination methods, errors caused by, 4-5
termination of datatransfers, 7-1to 7-2
TestSRQ routine, 7-15
timing errors, 4-4
TIMO status word condition
bit position, hex value, and type
(table), 3-6
description, B-2
troubleshooting and common questions. See
also debugging; NI Spy utility.
online problem-solving and diagnostic
resources, F-1
using Measurement & Automation
Explorer, 2-4
Windows 98/95, D-1 to D-8
common questions, D-5 to D-8
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Device Manager device status
code, D-3
EDVR error conditions, D-1 to D-2
enabling interrupts, D-4 to D-5
Windows 2000/NT, E-1 to E-3
turn OFF display (-) function, Interactive
Control utility, 6-9
turn ON display (+) function, Interactive
Control utility, 6-10

v

Visual Basic programming instructions, 3-12

W

WaitSRQ routine, 7-15
Web support from National |nstruments,
F-1toF-2
online problem-solving and diagnostic
resources, F-1
software-rel ated resources, F-2
Win32 and Win16 NI-488.2 applications
asynchronous event notification,
7-4t07-9
running, 3-17
running existing applications, 3-17
writing multithreaded applications,
7-9to 7-10
Windows 98/95
autopolling and interrupts, 7-14
changing GPIB device templates, 2-12
enabling/disabling N1-488.2 DOS
support, 2-13 to 2-14
running existing DOS NI-488.2
applications, 3-17
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troubleshooting and common questions,
D-1toD-8
common questions, D-5 to D-8
Device Manager device status
code, D-3
EDVR error conditions, D-1 to D-2
enabling interrupts, D-4 to D-5
viewing or changing settings
GPIB-ENET network, 2-15to 2-16
GPIB interface, 2-9 to 2-10
Windows 2000/NT
autopolling and interrupts, 7-14
changing GPIB device templates, 2-13
enabling/disabling NI1-488.2 DOS
support, 2-13 to 2-14
running existing DOS NI-488.2
applications, 3-18
troubleshooting and common questions,
E-1to E-3
viewing or changing GPIB interface
settings, 2-10 to 2-11
Worldwide technical support, F-2
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